Reader View ignores the HTML tag <base>, so links having a relative path are prefixed with current path (in address bar) rather than the path specified in the <base> tag.

RESOLVED DUPLICATE of bug 1173823

Status

()

Toolkit
Reader Mode
RESOLVED DUPLICATE of bug 1173823
3 years ago
2 years ago

People

(Reporter: qual-IT Software Quality Consulting, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Visit website www.software-quality.se/en/
Click the Reader View icon (in address bar)
Click any of the three links at the bottom of the page, for example "Software Quality Assurance".


Actual results:

Page "Requested page is missing" is displayed.
This is because the Firefox browser tries to navigate user to
http://www.software-quality.se/en/en/services/software-quality-assurance
, which is an non-existing path. Note that "en/" in the path is duplicated.

The failure occurs only when in Reader View.





Expected results:

The Firefox browser should instead have navigated me to
http://www.software-quality.se/en/services/software-quality-assurance, which it would have if it had not ignored the base path as specified in the <base> tag.
(Reporter)

Updated

3 years ago
Summary: In Reader View ignores the HTML tag <base>, so links having a relative path are prefixed with current path (in address bar) rather than the path specified in the <base> tag. → Reader View ignores the HTML tag <base>, so links having a relative path are prefixed with current path (in address bar) rather than the path specified in the <base> tag.

Updated

3 years ago
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1173823
You need to log in before you can comment on or make changes to this bug.