Editing the context URL should change/remove the favicon, as it's no longer relevant

RESOLVED WONTFIX

Status

P3
normal
Rank:
33
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: FlorinMezei, Unassigned)

Tracking

unspecified
Points:
2
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox40- wontfix, firefox41+ wontfix, firefox42 wontfix, firefox43 wontfix)

Details

(Whiteboard: [context])

(Reporter)

Description

3 years ago
Reproducible with: 
- Firefox 40 Beta 3 - BuildID: 20150709163524
- Firefox 40 Beta 2 - BuildID: 20150706172413

Reproducible on: Windows 7 x64, Windows 10 x86, Mac OS X 10.8.5

Steps to reproduce:
1. On one machine (machine A) open Firefox with a fresh profile and navigate to a web page (e.g. http://www.nytimes.com/).
2. Click on the Hello icon and then "Get Started".
3. Check "Let's talk about" -> "Start a conversation".
4. Copy the conversation link and open it on another machine (machine B) and join the conversation.
5. On machine A choose to edit the conversation context (pen icon overlayed on the video area).
6. Change the URL to something else (e.g. http://espn.go.com/) and save.

Expected results:
Since the original favicon is no longer relevant to the new URL it should be: removed, replaced with a default favicon, or updated to the correct favicon (not sure if even possible).

Actual results:
The favicon from the original URL keeps displaying in:
- the Hello panel
- the conversation window (machine A)
- the link clicker side (machine B)
Points: --- → 2
Flags: qe-verify+
Flags: firefox-backlog+
Priority: -- → P3

Comment 1

3 years ago
[Tracking Requested - why for this release]:
Nominating Hello Conversation Context issues for 40, as the amount of issues makes the feature questionable for release with this train.
tracking-firefox40: --- → ?

Comment 2

3 years ago
Adding a tracking flag for FF40. It would be nice to get a fix for this in time for 40 release as this is a new feature shipping in FF40.
tracking-firefox40: ? → +
Requesting tracking-, because this is not something we intend to fix for the Fx40 train.
Flags: needinfo?(rkothari)
status-firefox40: affected → wontfix

Comment 4

3 years ago
Untracking for FF40 as per Mike's suggestion. Showing the default icon would be nice but since we are in the end game in FF40 beta, let's leave it as is. We should try to fix it for FF41+
status-firefox41: --- → affected
tracking-firefox40: + → -
tracking-firefox41: --- → +
Flags: needinfo?(rkothari)

Updated

3 years ago
Rank: 33

Comment 5

3 years ago
Mike, is this something that is being investigated/fixed at the moment? I do not think this is a release blocking scenario so I will set the FF41 status as won't fix. But is this worth while to track for 42?
status-firefox41: affected → wontfix
Flags: needinfo?(mdeboer)
No, and also not a high enough priority for Fx43.
status-firefox42: --- → wontfix
status-firefox43: --- → wontfix
Flags: needinfo?(mdeboer)
Editable context is no longer part of the product, so this state can no longer happen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.