Windows crash in mozilla::dom::PBrowserChild::SendPDocAccessibleConstructor(mozilla::a11y::PDocAccessibleChild*, mozilla::a11y::PDocAccessibleChild*, unsigned __int64 const&)

RESOLVED DUPLICATE of bug 1181177

Status

()

--
critical
RESOLVED DUPLICATE of bug 1181177
3 years ago
3 years ago

People

(Reporter: jimm, Unassigned)

Tracking

({crash, topcrash})

Trunk
x86
Windows NT
crash, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s?, firefox42 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
Bug 1170153 originally tracked this crash but the fix there didn't address it. Two follow ups are now filed, this bug (Windows) and bug 1181177 (Linux).

https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Adom%3A%3APBrowserChild%3A%3ASendPDocAccessibleConstructor%28mozilla%3A%3Aa11y%3A%3APDocAccessibleChild*%2C%20mozilla%3A%3Aa11y%3A%3APDocAccessibleChild*%2C%20unsigned%20__int64%20const%26%29#tab-sigsummary

This is on nightly and aurora, and is a top crasher on both. It is also associated with e10s.
(In reply to Jim Mathies [:jimm] from comment #0)
> Bug 1170153 originally tracked this crash but the fix there didn't address
> it. Two follow ups are now filed, this bug (Windows) and bug 1181177 (Linux).

So I'm confused what the point of this bug is, do you have some evidence its different bugs on linux and windows? Off hand that seems kind of unlikely.
(Reporter)

Comment 2

3 years ago
(In reply to Trevor Saunders (:tbsaunde) from comment #1)
> (In reply to Jim Mathies [:jimm] from comment #0)
> > Bug 1170153 originally tracked this crash but the fix there didn't address
> > it. Two follow ups are now filed, this bug (Windows) and bug 1181177 (Linux).
> 
> So I'm confused what the point of this bug is, do you have some evidence its
> different bugs on linux and windows? Off hand that seems kind of unlikely.

I'm not surer honestly but maybe bill can answer that. If that's the case then we can dupe this to the linux bug and update the crash information over there. I just wanted something filed and showing up in crash stats under this signature for tracking purposes.
Flags: needinfo?(wmccloskey)
(Reporter)

Updated

3 years ago
Depends on: 1181177
Pretty sure it's a dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wmccloskey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1181177
You need to log in before you can comment on or make changes to this bug.