Closed Bug 1182495 Opened 7 years ago Closed 5 years ago

Partial Update Fail shows a UI, but shouldn't.

Categories

(Toolkit :: Application Update, enhancement)

All
Windows
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 893505

People

(Reporter: glind, Unassigned)

References

Details

Claim:  Telling users that a partial update failed just makes Fx look silly. When partial update fails, just go on to full update.  Don't mention it to user.  

Steps to repro:

1.  Have a partial update fail.  (??)
2.  See that there is a ui saying so, with an "ok" button
3.  Full update happens.

Desired:
1. record the partial update failure as needed (if it's in telemetry?).
2. hide the UI, continue to full updates.
3. (Maybe in nightly, or local builds, it should still show the UI, I don't know!)

(might be windows only.)
07:45 < mconley> actually, maybe needinfo ehsan - I don't think he notices cc's. :)
...
07:48 < Gijs> gregglind: ni :rstrong, look for update log files (sadly, can't recall where those live... searching the web might tell you?)
Flags: needinfo?(robert.strong.bugs)
This ui needs a lot of love and this should be folded into the work in bug 893505.
Severity: minor → enhancement
Depends on: 893505
Flags: needinfo?(robert.strong.bugs)
This should be fixed by the new doorhanger notification implemented in bug 893505
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893505
You need to log in before you can comment on or make changes to this bug.