Closed Bug 1182548 Opened 4 years ago Closed 3 years ago

ww3.lufthansa.com fails due to missing SSLv3 support

Categories

(Web Compatibility :: Desktop, defect)

Firefox 38
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: burnus, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 2015051400

Steps to reproduce:

https://ww3.lufthansa.com/de/en/Arrival-and-Departure-Result (via www.lufthansa.com -> Flights -> Flight Status -> submit) only supports SSLv3 and, hence, fails with Firefox 38.0/Linux ("ssl_error_unsupported_version")

BTW: https://www.ssllabs.com/ssltest/analyze.html?d=ww3.lufthansa.com reports it as "F".

See also: https://webcompat.com/issues/1366
Yes, they should remove the support of SSL3 and enable the support of TLS 1.0 at least.
Blocks: POODLEBITE
Status: UNCONFIRMED → NEW
Ever confirmed: true
Interestingly this SSLv3 only server supports secure renegotiation. I wonder if there was actually SSLv3 only load balancers/HSMs that was patched for that.
Fixed.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.