[Aries][RIL] No Voice mail is received when calling a device that enters Airplane mode during mid call.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: jthomas, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(17 attachments)

369.10 KB, text/plain
Details
377.85 KB, text/x-log
Details
539.44 KB, text/x-log
Details
7.58 KB, text/x-log
Details
406.05 KB, text/x-log
Details
447.31 KB, text/x-log
Details
360.38 KB, text/x-log
Details
40.68 KB, text/x-log
Details
13.24 KB, text/x-log
Details
356.31 KB, text/x-log
Details
8.08 KB, text/x-log
Details
302.29 KB, text/x-log
Details
12.14 KB, text/x-log
Details
307.44 KB, text/x-log
Details
9.36 KB, text/x-log
Details
778.71 KB, text/x-log
Details
519.53 KB, text/x-log
Details
(Reporter)

Description

3 years ago
Created attachment 8632186 [details]
logcat_20150710_1015.txt

Description:
If the user calls a device that enters Airplane mode while the call is being made the user will not receive a voice mail.


Repro Steps:

Prereq: Two devices with active SIMs.

1) Update a Aries to 20150709132856
2) Have device 1 call device 2.
3) While device 2 is receiving a call pull down notification tray and active Airplane mode.

Actual:
No Voice mail is received when calling a device that enters Airplane mode during mid call.

Expected:
It is expected that even though device 2 has entered Airplane mode while they are being called that device one will enter the voice mail message.

Environmental Variables:
Device: Aries 2.5 L
Build ID: 20150709132856
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: cc42883d641b720223054f29f096175e26a0b5f3
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 100%
See attached: Logcat & Video
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on the Flame 2.5, 2.2, 2.2 and the 2.0.

Result: User successfully reaches a voicemail message when the other device enters Airplane mode while receiving call.

Environmental Variables:
Device: Flame 2.5 Kk Full flash (319mb)
BuildID: 20150710010203
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: 2c91d57441fd
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.2 2.5 Kk Full flash (319mb)
Build ID: 20150710002505
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: e002005dc994
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 Kk Full flash (319mb)
Build ID: 20150710001202
Gaia: d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gecko: e6585848a94a
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 Kk Full flash (319mb)
Build ID: 20150710000209
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: 2f753ad1ea42
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
(Reporter)

Comment 2

3 years ago
Regarding Comment 1, I meant to say this also occurs on Flame 2.1. (2.2 was mentioned twice by accident.)
[Blocking Requested - why for this release]:

The user should be sent to voicemail so they can leave a message. Nominating 2.5?

Can we check Spark on Flame to see if this issue occurs?
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted
I was unable to reproduce this issue on the reported build as well as on other devices/branches. I get consistent results from Flame 2.5 KK, Aries 2.5 KK, and Aries 2.5 L:

When the abovementioned DUT enters airplane mode while incoming call is ringing, the caller gets a message saying "the wireless customer you're trying to reach is not available at this time. please try again later."

Device: Aries 2.5
BuildID: 20150709132856
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: cc42883d641b720223054f29f096175e26a0b5f3
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Reporter could you please try again?
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(jthomas)
Keywords: qawanted
After further investigation, this issue seems to be dependent on carrier. I tested further between AT&T and T-Mobile.

Here are some additional testing results:

T-M calling AT, AT enters airplane mode = T-M gets the call hung up (original bug)
AT calling AT, AT enters airplane mode = AT gets unable to reach message (comment 4 result)
AT calling T-M, T-M enters airplane mode = AT gets to actually leave a voicemail message to T-M
Hermes is this expected behavior based upon which carrier the user is using? I am not sure who the correct owner for RIL is at this time.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(hcheng)
Hsin-Yi, could you help check if this is a RIL issue?
Flags: needinfo?(hcheng) → needinfo?(htsai)
(In reply to Hermes Cheng[:hermescheng] from comment #7)
> Hsin-Yi, could you help check if this is a RIL issue?

Bevis, please help this, thank you.
Flags: needinfo?(htsai) → needinfo?(btseng)
Hi Hermes,

I wouldn't say that this is a regression according to the information we have so far and there is not much we can impact/access in B2G implementation.
The behaviour varies based upon multiple reasons:
1. The default configuration in carrier side when call is not reachable/not answered.
2. The SIM Subscriber's configuration in the carrier. (Whether the call will be forwarded to the voicemail if not reachable/not answer. You can check this from "Call Forward Settings" to see if the call is forwarded to a number that represents the voice mail number of the carrier.)
3. Did the modem tear down the connection from network properly when call is incoming?

To narrow down the problem, we need reporter to do the following comparison with the same test SIM:
1. Use the same test SIM cards as the same call originator/receiver on flame-kk. (This is useful to identify reason#1 and reason#2.)
2. If the result is different in Test#1, please have the same test SIM cards to run the tests on Aries with original Android Build instead to see if there is any difference. (This is useful to identify readn#3)

NI reporter to clarify this.
Flags: needinfo?(btseng)
(Reporter)

Comment 10

3 years ago
Both SIM Cards for the following tests were specifically using AT to AT.

If device 1 is calling and using a SIM card in slot 1 this issue does NOT occur.
Result: User will receive a voice mail after device 2 enters airplane mode.

However, if device one is calling with the SIM card in slot 2 this issue DOES occur.
Result: Device 1 does not receive a voice mail, call is dropped.


Note: Changing the SIM card for Flame device 2 in slots 1 or 2 does not seem to affect the outcome.


Environmental Variables:
Device: Flame 2.5 Kk Full Flash (319mb)
Build ID: 20150713010204
Gaia: e4b63559eba364892867eb381c3002d6518e5d6a
Gecko: eab21ec484bb
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.2 Kk Full Flash (319mb)
Build ID: 20150713002503
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: 8d59402ba85a
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 Kk Full Flash (319mb)
Build ID: 20150713001203
Gaia: d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gecko: 92049b3c4bb5
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 Kk Full Flash (319mb)
Build ID: 20150713000203
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: 05c79079e217
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.0: unaffected → affected
status-b2g-v2.1: unaffected → affected
status-b2g-v2.2: unaffected → affected
Flags: needinfo?(jthomas) → needinfo?(ktucker)
(Reporter)

Comment 11

3 years ago
However after calling an Aries with an original Android build entering Airplane mode the user on the flame kk will receive a voice mail message regardless of which port the SIM is located in.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
remove "regression" according to comment 10.

Hi John,

According to comment 11,
to narrow down the problem further between Aries(Android) and Aries(FxOS), 
Can you help to do the follow test twice with both main/radio logcat captured in both 2 run. 
  - The same reference phone with SIM#1 as caller and the same Aries with SIM#2 as callee.
  Where Aries(Android) is for the 1st run and Aries(FxOS) is for the 2nd run.

Note: For Aries(FxOS), please ensure that RIL related debug flag is enabled.
We suppose to see lots of logs tagged with "RIL Worker" in main log for FxOS build.

Thanks!
Keywords: regression
NI for comment 12 and the following question:
Does the caller reach the voicemail if the callee(Aries) reject the incoming call instead of turning airplane mode off with the same test SIMs?

Thanks!
Flags: needinfo?(jthomas)
(Reporter)

Comment 14

3 years ago
I was using two Spark devices for these tests. Aries to Rejecting Droid and Aries to Rejecting Aries. I am getting a Voicemail message regardless in this case. 8 Logcats have been attached. Please let me know if there is anything else I can do.
Flags: needinfo?(jthomas)
(Reporter)

Comment 15

3 years ago
Created attachment 8637406 [details]
mainAriesRejecting.log
(Reporter)

Comment 16

3 years ago
Created attachment 8637407 [details]
mainDroidRejecting.log
(Reporter)

Comment 17

3 years ago
Created attachment 8637409 [details]
radioAriesRejecting.log
(Reporter)

Comment 18

3 years ago
Created attachment 8637411 [details]
radioDroidRejecting.log
(Reporter)

Comment 19

3 years ago
Created attachment 8637412 [details]
mainAriestoRejectingAries.log
(Reporter)

Comment 20

3 years ago
Created attachment 8637413 [details]
mainAriestoRejectingDroid.log
(Reporter)

Comment 21

3 years ago
Created attachment 8637414 [details]
radioAriestoRejectingAries.log
(Reporter)

Comment 22

3 years ago
Created attachment 8637416 [details]
radioAriestoRejectingDroid.log
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage] → [QAnalyst-Triage+]
Hi John,

Thanks for collect the logs.

Unfortunately, I cannot find the scenario from both Aries(Android) and Aries(FxOS) that rejects an incoming call by turning the airplane mode ON.
It seems that both of them hangup the incoming calls from the reject button instead of turning off the airplane mode because the voice registration is still alive all the time. :(

According to comment 11 and comment 14, there seems to be something different when rejecting a call by turning on the airplane mode between Aries(Android) and Aries(FxOS).

Hence, could you do me a favour again to capture the main/radio logs on Aries(Android) and Aries(FxOS) with the test scenario that the user rejects the incoming call by turning on the airplane mode?

Thanks!
Flags: needinfo?(jthomas)
Keywords: qawanted
(Reporter)

Updated

3 years ago
Flags: needinfo?(jthomas)
QA Contact: jthomas
(Reporter)

Comment 24

3 years ago
Created attachment 8639585 [details]
AriesSettoAirplanemain.log
(Reporter)

Comment 25

3 years ago
Created attachment 8639586 [details]
AriesSettoAirplaneradio.log
(Reporter)

Comment 26

3 years ago
Created attachment 8639587 [details]
AriestoAirplaneAriesmain.log
(Reporter)

Comment 27

3 years ago
Created attachment 8639588 [details]
AriestoAirplaneAriesradio.log
(Reporter)

Comment 28

3 years ago
Created attachment 8639589 [details]
AriestoAirplaneDroidmain.log
(Reporter)

Comment 29

3 years ago
Created attachment 8639590 [details]
AriestoAirplaneDroidradio.log
(Reporter)

Comment 30

3 years ago
Created attachment 8639591 [details]
DroidSettoAirplaneMain.log
(Reporter)

Comment 31

3 years ago
Created attachment 8639592 [details]
DroidSettoAirplaneRadio.log
(Reporter)

Comment 32

3 years ago
I have attached the Radio and Main logs located for the different scenarios. Hopefully this will provide the information you are looking for. I noticed that regardless of whether the Aries was calling another Aries or Droid that was being set to Airplane mode in mid call that it will result in a voice mail regardless. Has this issue been fixed recently?
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to John Thomas [:Johnt] from comment #32)
> I have attached the Radio and Main logs located for the different scenarios.
> Hopefully this will provide the information you are looking for. I noticed
> that regardless of whether the Aries was calling another Aries or Droid that
> was being set to Airplane mode in mid call that it will result in a voice
> mail regardless. Has this issue been fixed recently?

No, we didn't do any fix on this.
I'll treat the priority of this bug lower if it's not reproducible any more.
In addition, it's not a normal use case to reject an incoming call by toggling airplane mode, IMO.
[triage] non-blocking as it's not a regression and a very abnormal case.
blocking-b2g: 2.5? → -

Comment 35

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.