Provide B2G boot logo on Xperia devices and others

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: gerard, Assigned: gerard)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Comment 1

3 years ago
> convert b2gimage.png -separate -swap 0,2 -combine b2gimage.h

And then remove the 16 first bytes.
(Assignee)

Comment 2

3 years ago
This is also something we should be able to do on the KK build. I have tested and verified it on L kernel already.
Blocks: 1111748
Flags: needinfo?(drs)
Summary: Provide B2G boot logo on aries-l and others → Provide B2G boot logo on Xperia devices and others
(Assignee)

Comment 3

3 years ago
Jacqueline, can you or some other UX people provide an image for this ? As a reminder, this is the very early stage boot logo.

The logos we see are:
 1. Kernel logo (the one in this bug), which is currently "SONY" branding
 2. Boot animation (the moving fox)
 3. Gaia System app logo (the Firefox OS branding)

What we would need for the kernel logo is just a static PNG (with color if you want). It's easier if we have a small (will be centered) branding on black background since we can use the same on all devices that uses this kernel instead of having to hack more.
Flags: needinfo?(jsavory)
Created attachment 8637802 [details]
Bring back / update this logo!
(Assignee)

Comment 5

3 years ago
Created attachment 8637821 [details]
b2gsplash.h
(Assignee)

Updated

3 years ago
Attachment #8637821 - Attachment is obsolete: true
(Assignee)

Comment 6

3 years ago
Adam, I'm not able to properly convert and make this displayed. Whatever the format or transformations I do, colors are always wrong on the device :(.
Flags: needinfo?(adam)
Created attachment 8637879 [details] [review]
Kernel PR
Flags: needinfo?(adam) → needinfo?(lissyx+mozillians)
Attachment #8637879 - Flags: feedback?(lissyx+mozillians)
steps to reproduce:

1. Ensure PNG format without alpha (fill it with black)
2. convert b2gimage.png -separate -swap 0,2 -combine b2gimage.h
3. remove first 15 bytes (first line of 12 then first three on second line, usually "0x35, 0x35, 0x0A,")
4. ???
5. PROFIT.
Flags: needinfo?(lissyx+mozillians)
Created attachment 8637899 [details] [review]
Kernel PR
Attachment #8637802 - Attachment is obsolete: true
Attachment #8637879 - Attachment is obsolete: true
Attachment #8637879 - Flags: feedback?(lissyx+mozillians)
Attachment #8637899 - Flags: review?(lissyx+mozillians)
(Assignee)

Updated

3 years ago
Flags: needinfo?(jsavory)
(Assignee)

Comment 10

3 years ago
Comment on attachment 8637899 [details] [review]
Kernel PR

Looks nice on Z3, Z3 Compact and Z3 Tablet Compact :)
Attachment #8637899 - Flags: review?(lissyx+mozillians) → review+
(Assignee)

Comment 11

3 years ago
https://github.com/mozilla-b2g/codeaurora_kernel_msm/commit/0417e112a780b9b2d4c71bf3ca2cc2c918c928f4
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(drs)
You need to log in before you can comment on or make changes to this bug.