crash in nsRefPtr<T>::assign_with_AddRef(mozilla::dom::Blob*) | nsBaseWidget::RemoveChild(nsIWidget*)

RESOLVED DUPLICATE of bug 1182919

Status

()

Core
Widget
--
critical
RESOLVED DUPLICATE of bug 1182919
3 years ago
3 years ago

People

(Reporter: juanb, Unassigned)

Tracking

({crash})

42 Branch
Unspecified
Windows
crash
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-a1bc7532-fc4d-4b62-acaa-1c9f32150712.
=============================================================

This is a recent crash that started on 7/11. This appeared in the list of explosive reports for Fx42. There are no correlations shown. Paypal.com appears in the list of URLs associated with this crash. The signature is similar to the one in bug 1182917. They might be related. This is also a content type crash.

You can see more reports at: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=nsRefPtr%3CT%3E%3A%3Aassign_with_AddRef%28mozilla%3A%3Adom%3A%3ABlob%2A%29+%7C+nsBaseWidget%3A%3ARemoveChild%28nsIWidget%2A%29


0 	xul.dll 	nsRefPtr<mozilla::dom::Blob>::assign_with_AddRef(mozilla::dom::Blob*) 	xpcom/base/nsRefPtr.h
1 	xul.dll 	nsBaseWidget::RemoveChild(nsIWidget*) 	widget/nsBaseWidget.cpp
2 	xul.dll 	mozilla::widget::PluginWidgetProxy::SetParent(nsIWidget*) 	widget/PluginWidgetProxy.cpp
3 	xul.dll 	nsPluginFrame::SetInstanceOwner(nsPluginInstanceOwner*) 	layout/generic/nsPluginFrame.cpp
4 	xul.dll 	nsPluginInstanceOwner::SetFrame(nsPluginFrame*) 	dom/plugins/base/nsPluginInstanceOwner.cpp
5 	xul.dll 	nsPluginFrame::DestroyFrom(nsIFrame*) 	layout/generic/nsPluginFrame.cpp
6 	xul.dll 	nsFrameList::DestroyFramesFrom(nsIFrame*) 	layout/generic/nsFrameList.cpp
7 	xul.dll 	nsContainerFrame::DestroyFrom(nsIFrame*) 	layout/generic/nsContainerFrame.cpp
8 	xul.dll 	nsContainerFrame::DestroyFrom(nsIFrame*) 	layout/generic/nsContainerFrame.cpp
9 	xul.dll 	nsContainerFrame::DestroyFrom(nsIFrame*) 	layout/generic/nsContainerFrame.cpp
10 	xul.dll 	nsFrameManager::Destroy() 	layout/base/nsFrameManager.cpp
11 	xul.dll 	PresShell::Destroy() 	layout/base/nsPresShell.cpp
12 	xul.dll 	nsDocumentViewer::DestroyPresShell() 	layout/base/nsDocumentViewer.cpp
13 	xul.dll 	nsDocumentViewer::Hide() 	layout/base/nsDocumentViewer.cpp
14 	xul.dll 	nsDocShell::SetVisibility(bool) 	docshell/base/nsDocShell.cpp
15 	xul.dll 	nsFrameLoader::Hide() 	dom/base/nsFrameLoader.cpp
16 	xul.dll 	nsHideViewer::Run() 	layout/generic/nsSubDocumentFrame.cpp
17 	xul.dll 	nsContentUtils::RemoveScriptBlocker() 	dom/base/nsContentUtils.cpp
18 	xul.dll 	nsDocumentViewer::DestroyPresShell() 	layout/base/nsDocumentViewer.cpp
19 	xul.dll 	nsDocumentViewer::Destroy() 	layout/base/nsDocumentViewer.cpp
20 	xul.dll 	nsDocumentViewer::Show() 	layout/base/nsDocumentViewer.cpp
21 	xul.dll 	nsPresContext::EnsureVisible() 	layout/base/nsPresContext.cpp
22 	xul.dll 	PresShell::UnsuppressAndInvalidate() 	layout/base/nsPresShell.cpp
23 	xul.dll 	PresShell::UnsuppressPainting() 	layout/base/nsPresShell.cpp
24 	xul.dll 	PresShell::sPaintSuppressionCallback(nsITimer*, void*) 	layout/base/nsPresShell.cpp
25 	xul.dll 	nsTimerImpl::Fire() 	xpcom/threads/nsTimerImpl.cpp
26 	xul.dll 	nsTimerEvent::Run() 	xpcom/threads/nsTimerImpl.cpp
27 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
28 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
29 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
30 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
31 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
32 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
33 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
34 	xul.dll 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp
35 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
36 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
37 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
38 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp
39 	plugin-container.exe 	content_process_main(int, char** const) 	ipc/contentproc/plugin-container.cpp
40 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
41 	plugin-container.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
42 	kernel32.dll 	BaseThreadInitThunk 	
43 	ntdll.dll 	RtlUserThreadStart 	
44 	kernel32.dll 	BasepReportFault 	
45 	kernel32.dll 	BasepReportFault
(Reporter)

Updated

3 years ago
QA Whiteboard: mozLATAM
See Also: → bug 1182917

Comment 1

3 years ago
I think that this as well as some other similar signatures - see top of https://crash-analysis.mozilla.com/rkaiser/2015-07-12/2015-07-12.firefox.42.explosiveness.html - are all the same cause as bug 1182921.

Updated

3 years ago
Duplicate of this bug: 1182917

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1182919
You need to log in before you can comment on or make changes to this bug.