Closed Bug 1182923 Opened 5 years ago Closed 4 years ago

AMD drive download form broken when privacy protection is enabled because submit script calls Omniture stuff, and the Omniture tracker is blocked

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1176495

People

(Reporter: rjward0, Unassigned)

References

()

Details

(Whiteboard: [js] [contentblock] [country-all] [needscontact] )

http://support.amd.com/en-us/download

STR:
Fill in on the form 
- Desktop Graphics
- Radeon R9 Series
- Radeon R9 2XX Series
- Windows 8.1 - 64 Bit

click Display Results button

Expected results:
Firefox should redirect to this page: http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064

Actual results: 
The form refreshes and the user is not redirected. 

http://forums.mozillazine.org/viewtopic.php?f=23&t=2946719#p14233037
http://forums.mozillazine.org/viewtopic.php?f=23&t=2946719#p14233049
Summary: AMD Driver Download form doesn't work on 64bit Firefox → AMD drive download form broken when privacy protection is enabled
This looks like an advocacy bug to me; moving it to desktop evangelism. I'm sure we know somebody there.
Component: Untriaged → Desktop
Product: Core → Tech Evangelism
Nothing else to expect when code like this is part of the JS for processing the form:

		//Process Omniture Tracking
		var s=s_gi(sTrackingAccounts);
		s.linkTrackVars='prop12,prop13,prop14,prop15,prop22,events';
		s.linkTrackEvents='event16';
		s.events='event16';
		s.trackingServer="metrics.amd.com";

sTrackingAccounts is not defined, likely because the Omniture tracker is blocked. This code should detect if s_gi and sTrackingAccounts exist and skip the Omniture part if not.
Summary: AMD drive download form broken when privacy protection is enabled → AMD drive download form broken when privacy protection is enabled because submit script calls Omniture stuff, and the Omniture tracker is blocked
Whiteboard: [js] [contentblock] [country-all] [needscontact]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176495
No longer blocks: tp-breakage
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.