Session is restored when running tests

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bnicholson, Assigned: bnicholson)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
We want a clean state for every test run, meaning we don't want to do any session restore. Looks like this regressed somewhere.
(Assignee)

Comment 1

4 years ago
Created attachment 8633039 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/723

We used to override the "should restore" logic in TestAppDelegate, but it looks like that got lost when FXCrashDetector landed. We have an IsTestRunning boolean in AppConstants, so we can just use that directly.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #8633039 - Flags: review?(sleroux)
Comment on attachment 8633039 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/723

Looks good
Attachment #8633039 - Flags: review?(sleroux) → review+
(Assignee)

Comment 3

4 years ago
https://github.com/mozilla/firefox-ios/commit/7f1b1fbfa72006f49ac2645a1d4a853192fe0093
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.