2,600 instances of "NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057" emitted from dom/base/nsContentUtils.cpp during linux64 debug testing

RESOLVED DUPLICATE of bug 1183845

Status

()

Core
DOM
--
trivial
RESOLVED DUPLICATE of bug 1183845
3 years ago
3 years ago

People

(Reporter: erahm, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

+++ This bug was initially created as a clone of Bug #1183845 +++

> 2566 [NNNNN] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file dom/base/nsContentUtils.cpp, line 3739

It's possible this is related to bug 1183845, but the spread of warnings is definitely different.

This warning [1] shows up in the following test suites:

> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-3-bm118-tests1-linux64-build0.txt:1079
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-2-bm67-tests1-linux64-build0.txt:884
> mozilla-central_ubuntu64_vm-debug_test-mochitest-other-bm53-tests1-linux64-build0.txt:589
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-browser-chrome-1-bm53-tests1-linux64-build0.txt:556
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-2-bm117-tests1-linux64-build8.txt:263
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-1-bm122-tests1-linux64-build19.txt:226
> mozilla-central_ubuntu64_vm-debug_test-mochitest-browser-chrome-3-bm122-tests1-linux64-build17.txt:185
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-2-bm53-tests1-linux64-build12.txt:134
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-1-bm123-tests1-linux64-build25.txt:122
> mozilla-central_ubuntu64_vm-debug_test-mochitest-2-bm67-tests1-linux64-build1.txt:121
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-5-bm52-tests1-linux64-build2.txt:109
> mozilla-central_ubuntu64_vm-debug_test-mochitest-5-bm115-tests1-linux64-build29.txt:63
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-3-bm115-tests1-linux64-build9.txt:51
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-2-bm120-tests1-linux64-build0.txt:44
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-4-bm122-tests1-linux64-build12.txt:33
> mozilla-central_ubuntu64_vm-debug_test-mochitest-e10s-3-bm51-tests1-linux64-build0.txt:32
> mozilla-central_ubuntu64_vm-debug_test-mochitest-jetpack-bm123-tests1-linux64-build2.txt:28
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-1-bm52-tests1-linux64-build11.txt:19
> mozilla-central_ubuntu64_vm-debug_test-mochitest-4-bm121-tests1-linux64-build0.txt:14
> mozilla-central_ubuntu64_vm-debug_test-crashtest-bm53-tests1-linux64-build28.txt:14
> mozilla-central_ubuntu64_vm-debug_test-mochitest-1-bm117-tests1-linux64-build1.txt:13
> mozilla-central_ubuntu64_vm-debug_test-mochitest-3-bm115-tests1-linux64-build21.txt:5
> mozilla-central_ubuntu64_vm-debug_test-mochitest-devtools-chrome-4-bm51-tests1-linux64-build3.txt:3
> mozilla-central_ubuntu64_vm-debug_test-mochitest-push-bm68-tests1-linux64-build20.txt:2
> mozilla-central_ubuntu64_vm-debug_test-cppunit-bm118-tests1-linux64-build12.txt:2
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-2-bm123-tests1-linux64-build2.txt:1
> mozilla-central_ubuntu64_vm-debug_test-reftest-e10s-1-bm68-tests1-linux64-build0.txt:1
> mozilla-central_ubuntu64_vm-debug_test-mochitest-gl-bm113-tests1-linux64-build14.txt:1

It shows up in 1590 tests. A few of the most prevalent:

> 66 - browser/devtools/webide/test/sidebars/test_telemetry.html
> 65 - dom/manifest/test/browser_ManifestObtainer_obtain.js
> 60 - layout/style/test/test_ch_ex_no_infloops.html
> 60 - layout/style/test/test_ch_ex_no_infloops.html
> 42 - toolkit/mozapps/extensions/test/browser/browser_discovery.js
> 41 - browser/components/sessionstore/test/browser_formdata_cc.js
> 40 - browser/devtools/webide/test/sidebars/test_runtime.html
> 38 - browser/devtools/webide/test/sidebars/test_autoselect_project.html
> 36 - dom/html/test/test_iframe_sandbox_navigation.html
> 36 - dom/html/test/test_iframe_sandbox_inheritance.html

[1] https://hg.mozilla.org/mozilla-central/annotate/e786406bc683/dom/base/nsContentUtils.cpp#l3739
Virtually all instances come immediately after 'NS_ENSURE_TRUE(domDoc && target) failed' (bug 1183845). Looking at the tests again they all seem to correlate as well.

Inspecting the code we can see the warning is generated by inspecting the rv of a call to |GetEventAndTarget| which is where the warning is emitted in bug 1183845.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183845
You need to log in before you can comment on or make changes to this bug.