crash in RtlFreeHeap | RtlFreeHeap | atiumdva.dll@0x1c8ac8

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: alex_mayorga, Assigned: dvander)

Tracking

({crash})

39 Branch
x86
Windows 8.1
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-060d49cb-932b-4108-8b3e-9e1f12150711.
=============================================================

https://crash-stats.mozilla.com/report/list?product=Firefox&signature=RtlFreeHeap+%7C+RtlFreeHeap+%7C+atiumdva.dll%400x1c8ac8

Looks like an ATI startup crash on Windows 8.1 that's most prevalent on 39.
Looks like it's primarily AMD wrestler and trinity cards, we might want to consider blacklisting for those.

dvander, this crash [1] shows a callstack where we don't currently have crash detection. Might be worth adding one there.

[1] https://crash-stats.mozilla.com/report/index/e5b7149b-574a-4ec9-9ea4-bcf712150715
It's worth noting that this is not a new signature as we have reports going back to Firefox 6. The prevalence Alex reports above is probably more about that having our largest recent user population and less about this being a regression in Firefox 39. 

I've included the top driver and device correlations in case we want to proceed with blacklisting.

Top drivers:
1 	8.982.10.6000 	 28.29 %
2 	8.982.10.5000 	 26.89 %
3 	8.982.9.0 	 21.37 %
4 	8.982.10.8000 	 15.93 %
5 	8.982.10.0 	  5.39 %
6 	8.982.10.1300 	  1.00 %
7 	8.982.10.2500 	  0.32 %
8 	8.982.10.1600 	  0.23 %
9 	8.982.10.1200 	  0.18 %
10 	13.251.9001.1001  0.09 %
11 	13.152.1.3000     0.05 %

Top devices:
1 	0x9802 	23.18 %
2 	0x9808 	14.26 %
3 	0x9809 	10.77 %
4 	0x9903 	9.19 %
5 	0x9990 	8.96 %
6 	0x6841 	4.12 %
7 	0x990a 	3.71 %
8 	0x9992 	3.53 %
9 	0x9806 	3.44 %
10 	0x980a 	2.90 %

Top URLs by a wide margin are facebook.com and youtube.com. It might be worth trying to get our hands on an AMD Radeon HD 6310 (top device above) and seeing if this can be reproduced at all. Let me know if you think that'd be worth the effort.
Taking to get an assignee for now.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Whiteboard: [gfx-noted]
I'll add crash detection support for this callsite in bug 1188876. It might be worth blacklisting here too but I'm not sure how to make that call.

Here's some data if it helps: for the top four driver versions above, these comprise 2730 out of 2897764 sessions (0.09%). That's about 0.67% of AMD sessions.

The top five devices are 35463 out of 2897764 sessions (1.22%), which is about 8.7% of AMD sessions.

So maybe it's reasonable to just blacklist these drivers?
Flags: needinfo?(jmuizelaar)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #2)
> 
> Top devices:
> 1 	0x9802 	23.18 %
> 2 	0x9808 	14.26 %
> 3 	0x9809 	10.77 %
> 4 	0x9903 	9.19 %
> 5 	0x9990 	8.96 %
> 6 	0x6841 	4.12 %
> 7 	0x990a 	3.71 %
> 8 	0x9992 	3.53 %
> 9 	0x9806 	3.44 %
> 10 	0x980a 	2.90 %

It would be interesting to see these devices broken out by generation/chipset using gpu-db. It looks like the majority of these are PALM devices. We have one of these in the Toronto office and it has problems. See bug 1181296.
Flags: needinfo?(jmuizelaar)
EVERGREEN :: PALM [54.55%]
> 1 	0x9802 	23.18 %
> 2 	0x9808 	14.26 %
> 3 	0x9809 	10.77 %
> 9 	0x9806 	 3.44 %
> 10 	0x980a 	 2.90 %

CAYMAN :: ARUBA [25.39%]
> 4 	0x9903 	 9.19 %
> 5 	0x9990 	 8.96 %
> 7 	0x990a 	 3.71 %
> 8 	0x9992 	 3.53 %

CAYMAN :: TURKS [4.12%]
> 6 	0x6841 	 4.12 %
David, are you still working on this? I see no reports of this since July and suspect this can just be closed.
Flags: needinfo?(dvander)
Nope.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dvander)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.