If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Small UI glitches in advanced properties dialog

VERIFIED DUPLICATE of bug 87637

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 87637
16 years ago
13 years ago

People

(Reporter: Giacomo Magnini, Assigned: Kevin McCluskey (gone))

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In a composer window, add an element (e.g. horizontal line) that has an advanced
properties dialog. The three tabs (HTML, inline, JS) look different:
- inline's listbox is smaller than the others two
- the lower fields (attribute/property and value) have different dimensions in
the three dialogs (in inline's tab they are misplaced due to prev comment)

Happens on my 0.9.7 (W2K), but happens also on alge's 2002010506/linux.
Don't know about Mac tho.

As a sidenote: is the property field correctly a textfield, or should it be a
dropdown box as in the other two tabs?
(Reporter)

Updated

16 years ago
Keywords: polish, ui

Comment 1

16 years ago
This should be easy: if you swap the textfield in inline with a dropdown box,
and make the valuefield in html attribs a bit ..eh.. shorter, as the y
dimension... (= to match the value box of inline and js.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Component: Compositor → Editor: Composer
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Updated

16 years ago
Blocks: 104624
(Reporter)

Comment 2

16 years ago
cmanske: sorry for cc-ing you without prior notice.
Couls you please confirm if this is a dupe of 87637 and if all the issues
reported are fixed ? Thanks a lot!

Comment 3

16 years ago
In the HTML panel, the "value" widget switches between a textfield and an
editable menulist; the latter if we have a prefilled list of values to supply.
In the inline CSS panel, both "Property" and "Value" are textfields.
In JS panel, user can't edit the even name, thus that widget is a menulist, which
is a bit taller and looks different. 
Fixes for the layout and sizes of all these widgets were checked in last night.


*** This bug has been marked as a duplicate of 87637 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified dup.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer blocks: 104624
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.