Closed Bug 1184312 Opened 4 years ago Closed 4 years ago

Remove old tracking protection/MCB shield

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 42
Iteration:
42.3 - Aug 10
Tracking Status
firefox42 --- verified

People

(Reporter: keeler, Assigned: bgrins)

References

Details

(Whiteboard: [fxprivacy] [campaign])

Attachments

(2 files, 1 obsolete file)

STR:
enable tracking protection (set privacy.trackingprotection.enabled to true)
visit a site with tracking elements (e.g. http://www.nytimes.com/ )
two shield icons appear (both the popup notification one with the chevron on the right side and the site identity one to the left of the globe icon)
Attached image Screenshot.png
I also see this problem on irccloud.mozilla.com.
That's expected for now as I'm working on bug 1175702, the last things that keeps us from removing the old MCB/TP shield. They'll both find a new home in the control center with Firefox 42.
Depends on: 1184447
Duplicate of this bug: 1184445
Component: General → Location Bar
No longer depends on: 1184447
Duplicate of this bug: 1186443
Flags: firefox-backlog+
Priority: -- → P2
Whiteboard: [fxprivacy]
Summary: tracking protection shield shows up twice → Remove old tracking protection/MCB shield
Points: --- → 3
Blocks: 1186181
Flags: qe-verify?
Hi Paolo, does this bug require QA verification?
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Iteration: --- → 42.3 - Aug 10
Flags: needinfo?(paolo.mozmail)
Priority: P2 → P1
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
Yeah, we should test that we don't have two shields in the location bar when tracking protection and/or Mixed Content Blocking are active.

By the way, other people should feel free to take the bug if they beat me to it.
Flags: qe-verify?
Flags: qe-verify+
Flags: needinfo?(paolo.mozmail)
Moving back to 'P2' and out of this iteration to free up time for other higher priority work.
Assignee: paolo.mozmail → nobody
Status: ASSIGNED → NEW
Iteration: 42.3 - Aug 10 → ---
Priority: P1 → P2
Whiteboard: [fxprivacy] [campaign] → [fxprivacy]
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Iteration: --- → 42.3 - Aug 10
Priority: P2 → P1
QA Contact: mwobensmith
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
No longer blocks: 1186925
Depends on: 1186925
Attached patch hide-bad-content-WIP.patch (obsolete) — Splinter Review
First version of code removal, based off of the WIP patch in Bug 1175702.  Handling test updates in Bug 1186925
Ongoing try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8a9be525283c

Note that this depends on patches from Bug 1175702 and 1186925.
Attachment #8642670 - Attachment is obsolete: true
Attachment #8644703 - Flags: review?(ttaubert)
Comment on attachment 8644703 [details] [diff] [review]
remove-bad-content.patch

Review of attachment 8644703 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! We should remove the old icons too:

(../shared/bad-content-blocked-16.png)
(../shared/bad-content-blocked-16@2x.png)
(../shared/bad-content-blocked-64.png)
(../shared/bad-content-blocked-64@2x.png)
(../shared/bad-content-unblocked-16.png)
(../shared/bad-content-unblocked-16@2x.png)
(../shared/bad-content-unblocked-64.png)
(../shared/bad-content-unblocked-64@2x.png)

bad-content-blocked-16.png seems to be used by the old not-in-content preferences file browser/components/preferences/privacy.xul. We should probably just switch that to the new TP icon, they're going away somewhat soon anyway.

r=me with the icons removed.
Attachment #8644703 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/5ea0445e2eff
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Verified fixed FF 42.0a2 (2015-08-25) Win 7, Ubuntu 14.04, OS X 10.10.
Status: RESOLVED → VERIFIED
Depends on: 1400976
You need to log in before you can comment on or make changes to this bug.