Closed Bug 1184768 Opened 5 years ago Closed 2 years ago

[Dialer] Call Banner does not reappear and inform users call has ended after banner leaves screen

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: AdamA, Unassigned)

References

()

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(1 file)

Attached file logcat
Description:
When the user is in a call and presses the home button they will go to the homescreen with a call banner at the top of the screen that will go away after a moment. If the call ends after the banner has left the screen it will not reappear and inform the user the call has ended.

Repro Steps:
1) Update a Aries to 20150716033647
2) Receive a call from another device and answer
3) Press the home button
4) Hang up the other phone after the call banner has disappeared
5) Observe size of text in the banner

Actual:
The text in the banner is very large.

Expected:
It is expected that the text size remains consistent

Environmental Variables:
Device: Aries 2.5 [Full Flash]
BuildID: 20150716033647
Gaia: 981c61cdeb527fac8f8383c110df0e749eff67ea
Gecko: 72835344333f
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: Video, logcat
Step 4, actual, and expected result are incorrect.

Step 4: Observe the top of the screen

actual:
"The user does not receive a banner informing them that the call ended"

Expected result:
It is expected that the user is informed when the call ends.

-----------------------------------------------------------
This issue DOES occur on Flame 2.5 through Flame 2.1.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
Build ID: 20150715160204
Gaia: b9968cdc4a1dee49848fed6159a59c378cea062d
Gecko: 49683d4e9ebd
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.1[Full Flash]
BuildID: 20150716001207
Gaia: cc24cce17ab2ebf79f6505103da714fc65bc5ec1
Gecko: 3e0074546463
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
The user does not receive a banner informing them that the call ended
------------------------------------------------
This behavior was different in Flame 2.0.

Result:
The banner remains onscreen until the call is ended.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]: The call banner was added in 2.1. We've lived with this issue for 2 releases, but it seems to me that one standard use case of the call banner is missing.
blocking-b2g: --- → 2.5?
This is bizarre, I've tested this not too far ago and the call ended banner always showed up correctly.
Confirmed, the end-of-call banner doesn't work anymore and this is a regression because it used to work. I must have tested this not two months ago and it was still working correctly. It might be nice to have a window; I'm putting the appropriate flags but I'll try to get a window myself when I have some time.
Just talked to :gsvelto on IRC. A fix might have been here a couple of months ago. Before performing the regression window, QA wanted to verify the state of master branch 1, 2 and 3 months ago. If we had a fix, let's proceed to a regular regression window. If not, let's consider we've always had this bug.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
The following are test results from Flame with build ID on left and observed behavior on right.

20150417010203 - repro
20150518010206 - repro
20150617010205 - repro
20150717010206 - repro

Not a regression within master branch.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Comms triage: Important missing case, but not important enough to hold the next release.
blocking-b2g: 2.5? → ---
Priority: -- → P1
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.