[DOGFOOD][PREF MIGRATION] migrate the "copies and folders" prefs

VERIFIED DUPLICATE of bug 10583

Status

P3
normal
VERIFIED DUPLICATE of bug 10583
20 years ago
2 years ago

People

(Reporter: sspitzer, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

migrate the 4.5 prefs

user_pref("mail.default_drafts", "IMAP://sspitzer@tintin/Drafts");
user_pref("mail.default_fcc", "/home/seth/nsmail/Sent");
user_pref("mail.default_templates","IMAP://sspitzer@tintin/Templates");
user_pref("news.default_fcc", "/home/seth/nsmail/Sent");

to the 5.0 prefs:

// QueueForLater (Outbox)
mail.default_sendlater_uri

// SaveAsDraft (Drafts)
mail.default_drafts_uri

// SaveAsTemplate (Templates)
mail.default_templates_uri

// SaveInSentFolder (Sent) -  nsMsgDeliverNow
mail.default_fcc_uri

// SaveInNewsSentFolder
mail.default_newsfcc_uri

Here's what I'm thinking:

"IMAP://sspitzer@tintin/Drafts"
would get changed into
"mailbox://sspitzer@tintin/Drafts"

"/home/seth/nsmail/Sent"
would get changed into
"mailbox://<pop user name>@<pop server>/Sent"

since there is only one pop account in 4.5, this will work.

I've assigned this bug to me, and I'll take care of it.

cc'ing alecf and rhp in case I haven't thought of something.
Status: NEW → ASSIGNED
Summary: [PREF MIGRATION] migrate the → [DOGFOOD][PREF MIGRATION] migrate the
Target Milestone: M10
accepting.
marking m10.
marking dogfood.

Comment 2

20 years ago
FYI...
I have a question on the meaning/use of FCC. In 4.x mail.default_fcc was where
all messages got saved after sending, BUT in 5.x we want FCC operations to be a
per message setting. Now if you change that on the UI, do we override the fcc
for that particular message or is it in ADDITION to this pref?

Thanks for the clarification.

- rhp

Comment 3

20 years ago
You already filed this bug against me:
http://bugzilla.mozilla.org/show_bug.cgi?id=10583
which one gets marked as a dupe?

Updated

20 years ago
Blocks: 11091
Summary: [DOGFOOD][PREF MIGRATION] migrate the → [DOGFOOD][PREF MIGRATION] migrate the "copies and folders" prefs
fix the summary.  it got cropped.

Comment 5

19 years ago
Bulk move mail/news M10 bugs to M11

Updated

19 years ago
Whiteboard: [PR1]

Comment 6

19 years ago
Pref migration needs to occur for PR1, so I added a note in the Status
Whiteboard
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
whoops, I did log this bug twice.  marking this one a duplicate.

*** This bug has been marked as a duplicate of 10583 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.