Closed Bug 1184817 Opened 6 years ago Closed 6 years ago

Horizontal scrolling doesn't work

Categories

(Firefox for iOS :: Browser, defect)

All
iOS 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: rnewman, Assigned: sleroux)

References

()

Details

Attachments

(1 file)

"I'm running b24 on iOS 8.4, and Fennec is struggling with a web page that has horizontal scrolling.  It wants to snap back to the original position when one wants to scroll horizontally to the right in the scrolling area.

The hardware is an iPad HD.

Note the same page works as expected in Safari Mobile."

Presumably this is our swipe handling.
Testing this on the simulators with the URL and the scrolling seems fine?
Flags: needinfo?(rnewman)
Try on a device?
Flags: needinfo?(rnewman)
Might require zooming first. Brian hypothesizes relationship with scrollbar bug.
Flags: needinfo?(sleroux)
STR:

1. Navigation to bugzilla.mozilla.org
2. Zoom into page
3. Perfrom a mixture of vertical horizontal scrolling

Expected:

Page should scroll smoothly

Actual:

Page jitters

------

My gut says that the jittering is coming from the code that 'stablizes' the scroll view from scrolling while the toolbars are animating. We force the scroll view to not scroll while the toolbars are moving to prevent 'double' scrolling that gets caused by the scroll view scrolling + the toolbar animating.
Flags: needinfo?(sleroux)
Assignee: nobody → sleroux
Going to take this bug and see if some of the scrolling code I wrote on another branch will fix this.
Status: NEW → ASSIGNED
Blocks: 1185560
Comment on attachment 8637419 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/784

LGTM. Scrolling performance is still not great on bugzilla.mozilla.org - but then I tried it in Safari and it was just as bad so I it's just bugzilla. 

I noticed that scrolling occasionally seemed to stall briefly as we displayed and hid the bottom toolbar. Is this part of the same bug do you think or a separate one?
Attachment #8637419 - Flags: review?(etoop) → review+
I can kind of reproduce this if I'm panning + scrolling at the same time when the page size is close to the viewport size. Is this what you were referring to?
I'll file a separate bug for this.
Merged
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.