If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Editor menus put editor window in background

VERIFIED DUPLICATE of bug 11266

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 11266
18 years ago
9 months ago

People

(Reporter: jay, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Not sure if this is the right component, and this might be a dup, but i don't
recall seeing this on 8/12 builds.  If you open up the editor and click on the
menu, the menu pops up but the editor window is moved behind the apprunner
window.  You can't see the editor window, but the menu remains on top.

Build: Win32 1999081308 (chrome displays 1999070614)

Updated

18 years ago
Assignee: hyatt → rods

Comment 1

18 years ago
This is a dup of the focus problem rods is working on for combo boxes.
(Assignee)

Updated

18 years ago
Depends on: 9636
(Assignee)

Comment 2

18 years ago
This has to do with mouse capture and GFX scrollbars. I think this problem was
originally described as being part of a different bug that got closed out. I
will leave this new/assigned and will make it dependent on GFX scrollbars.
Dropdown comboboxes will not work right if we turn on mouse capture to make this
problem go away.

Updated

18 years ago
OS: Windows 98 → All

Comment 3

18 years ago
changing platform as this is XP - but I guess not Mac b/c of the way menus work.
The problem is also much more widespread. It's all menus in the whole app.
to repro:
1. pull down a menu
2. Click in the title bar to focus and drag window.
3. notice the window moves and the menu stays put.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
*** This bug has been marked as a duplicate of 11266 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED
QA Contact: phillip → cpratt
You need to log in before you can comment on or make changes to this bug.