Startup crash on latest nightly

VERIFIED DUPLICATE of bug 1185239

Status

()

--
critical
VERIFIED DUPLICATE of bug 1185239
4 years ago
4 years ago

People

(Reporter: kats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I just updated to the latest nightly on a Nexus 4 and it's consistently crashing on startup, right around when Gecko loads. Not much in logcat.

Crash reports:
2015-07-18 14:11 bp-1378954d-2ce8-41cc-8cd6-32e132150718
2015-07-18 14:11 bp-589ff8da-4e63-43f3-9028-e6e222150718
2015-07-18 14:10 bp-a4bcf71a-d05c-4459-a644-891742150718
2015-07-18 14:10 bp-ce669252-de14-4f00-b318-ddb732150718

These point to the crash being in UpgradeHostToOriginAndInsert in extensions/cookie/nsPermissionManager.cpp, last touched by Michael Layzell. That was back in June though so it may not be related.

Comment 1

4 years ago
I imagine that this is because of the same reason as bug 1185239, can you try the patch to see if it helps you?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bugmail.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1185239
I'll try the patch; I'll have to do local builds with and without the patch and I'm going to be in and out so it may be a couple of hours. If you do a try build  (Android API11+) that would be easier for me to verify. Leaving ni on me until my local builds are done.
Flags: needinfo?(bugmail.mozilla)
I hit this startup crash all through this weekend, too. Latest nightly (which I downloaded & installed manually) has no startup crash. --> Marking VERIFIED dupe (/ fixed).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.