cells of same column in different rows suddenly get different widths

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: philip, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020106
BuildID:    2002010621

Under certain conditions (and I can't isolate those), cells of the same column
in different rows lose their width, and each cell becoms just large enough to
hold its contents.  Any empty space from the right edge of the last cell to the
right edge of the table is filled with the table background colour.  This is
weird, because all cells in a column should have the same width, unless a cell
spans multiple columns.

Reproducible: Always
Steps to Reproduce:
1.visit the url pasted above
2.see the table with the calendar in it
3.click on "Whole course Schedule"
4.see the table now
5.click on the browser's back button
6.see the table now
7.now have a look at http://www.ncst.ernet.in/~etu/calendar/PGDST1.shtml
8.see the table

Actual Results:  The table is rendered correctly in all cases except the first
(steps 1 & 2). 
The contents of PGDST1.shtml and the first url are identical

Expected Results:  The table should render the same way in all cases

I've also found, that if the <h2> element to the right of the table does not
span more than one line, then the table renders correctly evertime.

*** This bug has been marked as a duplicate of 90211 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
 This bug can be dupe of Bug # 90211. But when I went through the bug #90211 it 
is the problem with the <div> tags. I tried to minimise the code of the given 
URL which is attached to this bug, It appeared that the problem is with the % 
width in <th> tag and the incremental reflow( Since when I view the same URL 
from my local machine there is no problem that was described in this bug). 
How ever in the test case that I was going to attach the width of the cells are 
not consistant which they should be. 

Comment 3

17 years ago
Created attachment 64043 [details]
reduced testcase attached

The width of all the cells should be consistant but they are not. Its more
visible in the second last cell(FRI).

Comment 4

17 years ago
 I am reopening this bug.. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

17 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020115

Perhaps the Mozilla collapses the columns because it is trying to accomodate the
width="1%" in the table tag. NS4 behaved differently (expanded the columns to
accomodate the table width).  If the table width is not set, the columns are the
"proper" width.

Comment 6

17 years ago
I'm not seeing this. it seems to be working great on today's build.  If someone 
else can still see this, can they re-open AND post some screenshots or something 
showing the problem. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Created attachment 68287 [details]
Screenshot of this bug

The attached file shows the bug in action.  Full url is
http://www/~etu/calendar/PGDST.shtml?fac=dbms;year=2002;month=2;date=7;family=corner


I'm using build 2002020611 on linux 2.4.17

Comment 8

17 years ago
I think Amarendra and I misunderstood the original report, but this is still WFM
(build 2002021412).  The behavior shown in the screenshot is definitely a bug.

Comment 9

17 years ago
 I agree with Andrew and Anthony. Marking verified. 
Status: RESOLVED → VERIFIED
Component: HTMLTables → HTMLFrames
You need to log in before you can comment on or make changes to this bug.