Closed Bug 1185350 Opened 7 years ago Closed 6 years ago

Irregular playback on specific webm video

Categories

(Core :: Audio/Video: Playback, defect)

37 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mozbugrep, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached video 1426819446137.webm
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Environment:
- Windows 7
- Firefox 39
- Low end nVidia card
- 1280x1024 screen resolution

1. Open attached webm (warning: slightly NSFW)
2. Play


Actual results:

Video paused for a second at 0:00 (almost 0:01) and 0:03. Might have something to do with encoding.


Expected results:

Video should have a smooth playback. I have tried opening other 1920x1080 webms and they don't show this anomaly.
Component: Untriaged → Video/Audio
Product: Firefox → Core
Regression range:
good=2014-12-30
bad=2014-12-31
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=67872ce17918&tochange=88037f94b7d7

Suspected bug: Bug 1114840
Blocks: 1114840
Flags: needinfo?(bobbyholley)
Keywords: regression
Version: 39 Branch → 37 Branch
Flags: needinfo?(bobbyholley) → needinfo?(jyavenard)
can't reproduce it with the new webm reader (bug 1148102).

Will push this one today and ask you to test it again on this machine.

It adds full async decoding, performance should be much better.
Flags: needinfo?(jyavenard)
Component: Audio/Video → Audio/Video: Playback
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.