Closed Bug 1185365 Opened 4 years ago Closed 4 years ago

Cookie exceptions list doesn't accept URL starts with http:// or https://

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 42
Tracking Status
firefox41 --- unaffected
firefox42 + fixed

People

(Reporter: yamadat501, Assigned: ehsan)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Open Cookie exceptions dialog.
2. Enter or Copy/Paste a URL starts with http:// or https://
3. Select a rule.

Expected result:
New rule is accepted and display correctly.

Actual result:
Display "moz-nullprincipal:~" in URL field and rule becomes invalid.
So, I can't register exception rules for various sites using https (for example: bugzilla.mozilla.org!).

Regression range:
Not tested. But probably the problem happens in 07-18 and 07-19 nightly.
Are changes in Permission Manager related?
In browser/components/preferences/permissions.js, there is unneeded 'let' at line 91...?
Assignee: nobody → ehsan
Attachment #8636661 - Flags: review?(michael)
Attachment #8636661 - Flags: review?(michael) → review+
https://hg.mozilla.org/mozilla-central/rev/c980a7040d69
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Tracking because regression and fixed in 42.
You need to log in before you can comment on or make changes to this bug.