Closed Bug 1185447 Opened 6 years ago Closed 5 years ago

location bar autocomplete ignores edits in url

Categories

(Firefox :: Untriaged, defect)

42 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: atiware, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150719030219

Steps to reproduce:

1. clear your history (visited sites and cache)
2. close all FF tabs/windows if any
3. open a new tab and go to the site https://en.wikipedia.org/wiki/Firefox
4. close the tab and open a new one
5. now we trying to visit the wikipedia main site as follows
6. enter wiki in the location bar
7. a previously visited wikipedia site appears in the autocomplete dropdown
8. use the cursor key to select that wikipedia entry (but don't hit enter)
9. now the location bar contains the previously visited wikipedia site
10. click in the location bar at the end of the url and delete with backspace until it contains only https://en.wikipedia.org
11. hit enter


Actual results:

the site https://en.wikipedia.org/wiki/Firefox loads


Expected results:

should load the url as shown in the location bar. in this case https://en.wikipedia.org
Thanks for the report! I've tried this a few times with the latest version of Firefox, using a fresh profile, and cannot reproduce the problem. I'm also on a Mac.

Are there any other steps I can try? Do you have any add-ons installed?
Flags: needinfo?(atiware)
i created a new fresh profile. the attached screen recording shows the bug.
steps:
00:16 with CMD-V pasting the previously copied url: https://en.wikipedia.org/wiki/Firefox
00:24-00:25 entering wiki in a new tab and pressing the down arrow once
00:26-00:28 deleting with backspace until only https://en.wikipedia.org is displayed in location bar
00:29 pressing enter
00:30 https://en.wikipedia.org/wiki/Firefox loads
Flags: needinfo?(atiware)
Attached video the bug in action
Thanks Attila!

Do you have any add-ons installed?
Flags: needinfo?(atiware)
not in that profile. the screen recording was created with a fresh profile without installing any addons.

how i make it:
started terminal
cd /Applications/FirefoxNightly.app/Contents/MacOS/ 
./firefox -ProfileManager
created a new profile and started with that profile
recorded the video
Flags: needinfo?(atiware)
Agggh, I still cannot reproduce it :(
you made me curious, so i made an another try.
1. deleted /Applications/FirefoxNightly.app
2. deleted /Users/myusername/Library/Application Support/Firefox
3. downloaded Nightly with Safari, installed it under Applications
4. see the second video
4.1 entering moz
4.2 pressing the arrow-down key once (and so selecting https://www.mozilla.org/en-US/about from list)
4.3 backspace until https://www.mozilla.org left
4.4 pressing enter

the same issue, but here demonstrated with www.mozilla.org. In this case firefox loads the about page (which i previously selected from dropdown) instead of the index site as shown in the location bar.
when i enter www.mozilla.org without selecting anything from dropdown, it loads https://www.mozilla.org/en-US/ as expected.

is there anything else i can try?
Could not reproduce.

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151001142456

[testday-20151002]
I was able to reproduce the issue on Mac OS X 10.10.4 using Firefox 42.0 (20150719030219) and the str from Comment 0.
The issue is no longer reproducible on the Latest Nightly 44.0a1 (20151011030229) or on the Firefox 42.0 beta 5 (20151008162217) builds.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.