Closed Bug 1185479 Opened 4 years ago Closed 4 years ago

Can't execute the UI tests because of mozlog

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-master fixed)

RESOLVED FIXED
Tracking Status
b2g-master --- fixed

People

(Reporter: jlorenzo, Assigned: jlorenzo)

References

Details

(Keywords: qablocker)

Attachments

(1 file)

STR
1. Delete you virtualenv, create it and install the deps.
2. Execute on test

You get the following:

> adb forward tcp:2828 tcp:2828 && gaiatest --testvars=testvars.json --address=localhost:2828 --timeout=30000 --type=b2g  gaiatest/tests/functional/contacts/test_import_contacts_from_gmail.py --restart
>
> Traceback (most recent call last):
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/.env/bin/gaiatest", line 9, in <module>
>     load_entry_point('gaiatest==0.33', 'console_scripts', 'gaiatest')()
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/.env/lib/python2.7/site-packages/pkg_resources/__init__.py", line 558, in load_entry_point
>     return get_distribution(dist).load_entry_point(group, name)
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/.env/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2682, in load_entry_point
>     return ep.load()
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/.env/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2355, in load
>     return self.resolve()
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/.env/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2361, in resolve
>     module = __import__(self.module_name, fromlist=['__name__'], level=0)
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/gaiatest/__init__.py", line 5, in <module>
>     from gaia_test import *
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 18, in <module>
>     from file_manager import GaiaDeviceFileManager, GaiaLocalFileManager
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/gaiatest/file_manager.py", line 12, in <module>
>     class GaiaFileManager(object):
>   File "/home/jlorenzo/git/gaia/tests/python/gaia-ui-tests/gaiatest/file_manager.py", line 16, in GaiaFileManager
>     def __init__(self, device, log_level=mozlog.ERROR):
> AttributeError: 'module' object has no attribute 'ERROR'
Assignee: nobody → jlorenzo
Summary: Can't execute the UI tests because of mozlogs → Can't execute the UI tests because of mozlog\
Summary: Can't execute the UI tests because of mozlog\ → Can't execute the UI tests because of mozlog
We don't depend on mozlog directly. It's included by mozdevice and its own dependencies. Everything was bumped in bug 1014760.
Blocks: 1014760
Keywords: qablocker
Apparently this was caused by the release of https://pypi.python.org/pypi/mozlog
Not sure where that repository is based. I guess it's not https://github.com/mozilla/mozlog but it sure is confusing.
Comment on attachment 8636000 [details] [review]
[gaia] JohanLorenzo:bug-1185479 > mozilla-b2g:master

We have to pin each of the sub-dependencies. If we don't, we can end up like:
> mozdevice 0.45 includes mozprofile >= 0.24 (that is to say 0.25) which includes mozlog 3.0.
Attachment #8636000 - Flags: review?(npark)
Attachment #8636000 - Flags: review?(martijn.martijn)
Comment on attachment 8636000 [details] [review]
[gaia] JohanLorenzo:bug-1185479 > mozilla-b2g:master

Side note: I found the version numbers in attachment 8635292 [details] [diff] [review], from bug 1014760.
Blocks: 1185501
Comment on attachment 8636000 [details] [review]
[gaia] JohanLorenzo:bug-1185479 > mozilla-b2g:master

Works fine when testing locally.
Attachment #8636000 - Flags: review?(martijn.martijn) → review+
Attachment #8636000 - Flags: review?(npark) → review+
There was a short time where I had published the new mozlog but not the new mozdevice (which depended on the new mozlog). So the error you got was likely because of that (this has since been fixed). If you only depend on mozdevice, just adding mozdevice >= 0.46 should be enough. That being said, pegging specific versions is a good idea if you want to avoid future surprises :)
Merged in master at: https://github.com/mozilla-b2g/gaia/commit/0556fe1f49ba53dcadedbb7e6aa0ad1178cc7285
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.