Ctrl+R does not work in text box/textarea box

VERIFIED DUPLICATE of bug 72352

Status

()

VERIFIED DUPLICATE of bug 72352
17 years ago
17 years ago

People

(Reporter: philip, Assigned: alexsavulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020106
BuildID:    2002010621

Ctrl+R has no effect when focus is in a text box or a textarea box.  It works if
focus is on a list box or command button.

Reproducible: Always
Steps to Reproduce:
1.go to any page with a form, and at least one text entry box
2.set focus on the text entry box
3.press Ctrl+R

Actual Results:  Nothing happens

Expected Results:  The page should reload

Comment 1

17 years ago
WFM 2002010608/WinNT4
Confirming, Linux 2002010607
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

17 years ago
Additionally, following are Ctrl+keys that work and do not work (linux).  

Work as usual:

Ctrl+G - find next (but Ctrl+F doesn't work)
Ctrl+I - page info
Ctrl+L - goes to url bar
Ctrl+O - file open dialog box
Ctrl+Q - quit
Ctrl+S - save as
Ctrl+T - new tab

special for textbox:
Ctrl+A - cursor start of line
Ctrl+B - cursor left (back)
Ctrl+C - copy selection
Ctrl+D - delete char after cursor
Ctrl+E - cursor end of line
Ctrl+F - cursor right (forward)
Ctrl+H - backspace (^H)
Ctrl+K - kill to end of line
Ctrl+N - cursor down (next line)
Ctrl+P - cursor up (prev line)
Ctrl+R - redo last undo
Ctrl+U - Kill line
Ctrl+V - paste from clipboard
Ctrl+W - delete prev word
Ctrl+X - cut selection
Ctrl+Z - undo

unknown:
Ctrl+J
Ctrl+M

behaviour should be consistent.  either all should not work, or all should work.
 I think there should be an additional modifier to make these things work in
text areas.  A simple text box doesn't require so many control characters. 
Ctrl+C, X, V are standard, and have similar usage inside and outside.

Maybe this will help
Don't we already have a dupe of this?
Whiteboard: DUPEME

Comment 5

17 years ago
Cc'ing some editor folks who know about text widget keybindings.

Comment 6

17 years ago
Sairuh, what's the master bug to which we're duping these "confusion about all
the conflicting key bindings in linux" bugs?
Duplicate of "Make emacs textfield keybindings a pref" 

*** This bug has been marked as a duplicate of 72352 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
thanks boris!

yep, bug 72352 is the one, akkana. :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.