Assertion failure: ShouldIntercept() (This can only be called on channels that can be intercepted),

RESOLVED DUPLICATE of bug 1179399

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1179399
3 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

3 years ago
found while working on bughunter: so not sure how to reproduce 
- was only hitting the homepage button while a website was loading


Assertion failure: ShouldIntercept() (This can only be called on channels that can be intercepted),
at c:/Users/mozilla/debug-builds/mozilla-central/netwerk/protocol/http/HttpBaseChannel.cpp:1437
#01: mozilla::dom::ChannelInfo::ResurrectInfoOnChannel (c:\users\mozilla\debug-builds\mozilla-centra
l\dom\fetch\channelinfo.cpp:96)
#02: mozilla::net::InterceptedChannelChrome::SetChannelInfo (c:\users\mozilla\debug-builds\mozilla-c
entral\netwerk\protocol\http\interceptedchannel.cpp:256)
#03: mozilla::dom::workers::`anonymous namespace'::FinishResponse::Run (c:\users\mozilla\debug-build
s\mozilla-central\dom\workers\serviceworkerevents.cpp:128)
#04: nsThread::ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\threads\nsthrea
d.cpp:867)
#05: NS_ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\glue\nsthreadutils.cpp
:277)
#06: nsThread::Shutdown (c:\users\mozilla\debug-builds\mozilla-central\xpcom\threads\nsthread.cpp:66
5)
#07: nsRunnableMethodImpl<enum nsresult (__stdcall nsIThread::*)(void),1>::Run (c:\users\mozilla\deb
ug-builds\mozilla-central\firefox-debug\dist\include\nsthreadutils.h:830)
#08: nsThread::ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\threads\nsthrea
d.cpp:867)
#09: NS_ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\glue\nsthreadutils.cpp
:277)
#10: nsThread::Shutdown (c:\users\mozilla\debug-builds\mozilla-central\xpcom\threads\nsthread.cpp:66
5)
#11: nsRunnableMethodImpl<enum nsresult (__stdcall nsIThread::*)(void),1>::Run (c:\users\mozilla\deb
ug-builds\mozilla-central\firefox-debug\dist\include\nsthreadutils.h:830)
#12: nsThread::ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\threads\nsthrea
d.cpp:867)
#13: NS_ProcessNextEvent (c:\users\mozilla\debug-builds\mozilla-central\xpcom\glue\nsthreadutils.cpp
:277)
#14: mozilla::ipc::MessagePump::Run (c:\users\mozilla\debug-builds\mozilla-central\ipc\glue\messagep
ump.cpp:95)
#15: MessageLoop::RunInternal (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\m
essage_loop.cc:234)
#16: MessageLoop::RunHandler (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\me
ssage_loop.cc:228)
#17: MessageLoop::Run (c:\users\mozilla\debug-builds\mozilla-central\ipc\chromium\src\base\message_l
oop.cc:202)
#18: nsBaseAppShell::Run (c:\users\mozilla\debug-builds\mozilla-central\widget\nsbaseappshell.cpp:16
7)
#19: nsAppShell::Run (c:\users\mozilla\debug-builds\mozilla-central\widget\windows\nsappshell.cpp:18
0)
#20: nsAppStartup::Run (c:\users\mozilla\debug-builds\mozilla-central\toolkit\components\startup\nsa
ppstartup.cpp:281)
#21: XREMain::XRE_mainRun (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp
:4288)
#22: XREMain::XRE_main (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:43
85)
#23: XRE_main (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nsapprunner.cpp:4474)
#24: do_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:212)
#25: NS_internal_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:39
9)
#26: wmain (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nswindowswmain.cpp:138)
#27: __tmainCRTStartup (f:\dd\vctools\crt\crtw32\startup\crt0.c:255)
#28: BaseThreadInitThunk[kernel32 +0x4ee1c]
#29: RtlInitializeExceptionChain[ntdll +0x637eb]
#30: RtlInitializeExceptionChain[ntdll +0x637be]
Flags: needinfo?(bkelly)
Whiteboard: [necko-backlog]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bkelly)
Resolution: --- → DUPLICATE
Duplicate of bug: 1179399
You need to log in before you can comment on or make changes to this bug.