"Too large subtable" error

RESOLVED WONTFIX

Status

Mozilla Developer Network
General
--
minor
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: shobson, Unassigned)

Tracking

({in-triage})

Details

(Reporter)

Description

3 years ago
When hard refreshing a page the following error appears in the console log:

"downloadable font: kern: Too large subtable., table discarded (font-family: "Open Sans Light" style:normal weight:normal stretch:normal src index:1) source: https://mozorg.cdn.mozilla.net/media/fonts/OpenSans-Light-webfont.woff"

It does not appear to be interfering with the code displaying, at least not in FF.
:pmac - seen this before? looks like it's happening on mozilla.org too ...
Severity: normal → minor
Flags: needinfo?(pmac)
Keywords: in-triage
I've not, but I've not exactly looked. Something you've seen Craig?
Flags: needinfo?(pmac) → needinfo?(craigcook.bugz)
So after a little digging I'm theorizing this is an issue with the Open Sans font itself, not anything in our code or infrastructure. Searching for that error message turns up a few other people talking about it and it's always in reference to Open Sans.

A kerning table is a set of instructions within a digital font file telling renderers how to kern certain character combinations. Open Sans has such a massive character set that it must also have a massive kerning table, apparently too much for the browser to handle, so it discards large chunks of it. Since it doesn't appear to significantly impact rendering, perhaps the chunks it discards are the ones for characters it's not rendering. So maybe this is just a browser doing what it should and it's only annoying that the error gets logged every time. I'd defer to someone with more expertise in how browsers process and render fonts.

I think the only real fix for this would be to either reduce the kerning tables in Open Sans (something we can't really do) or to use a subsetted copy of Open Sans with fewer characters (we load the full unsubsetted font so we can support a lot of locales; subsetting will impact l10n). 

Apart from that I don't think there's much we can do, and we probably don't need to worry much about it. I'm inclined to call this a wontfix.
Flags: needinfo?(craigcook.bugz)
Defer to Stephanie to call it WONTFIX or keep it open.
Flags: needinfo?(shobson)
(Reporter)

Comment 5

3 years ago
Happy to wont fix. Between the fact that the font hosting situation is going to change soon and that fira sans is on the horizon I think we will end up addressing this as part of other work.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(shobson)
Resolution: --- → WONTFIX
Duplicate of this bug: 1191338
Duplicate of this bug: 1211993
You need to log in before you can comment on or make changes to this bug.