Closed Bug 1186325 Opened 6 years ago Closed 6 years ago

Intermittent browser_contentSearchUI.js | State - Structures begin differing at:

Categories

(Firefox :: Search, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 42
Tracking Status
firefox40 --- unaffected
firefox41 --- unaffected
firefox42 --- fixed
firefox-esr38 --- unaffected

People

(Reporter: cbook, Assigned: nhnt11)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=11972399&repo=mozilla-inbound

17:31:42 INFO - 418 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | State - Structures begin differing at:
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #6)
> Started on
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=d82fc1a3328b
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/9a073bb6c768 seems
> the most-likely culprit.

seems more caused by 1171344
Depends on: 1171344
Flags: needinfo?(dd.mozilla)
Seems like the selected item in the suggestions table isn't deterministic in some cases when the table gets hidden for some reason.
Patch for bug 1182338 makes it deterministic, so this failure should go away once that lands (which should be soon, just pushed it to try https://treeherder.mozilla.org/#/jobs?repo=try&revision=585c9e97450d).
Attached patch Possible patchSplinter Review
Did some digging, seems to be a timing issue between the mouseout and mousemoved listeners. My guess is that execution returns to the test script after the mouseout listener has fired but before mousemoved. This patch attempts to fix that by sending the ack for the mousemove message after a mousemove event has occurred on the target element.

If this is indeed the issue, it isn't surprising that bug 1182338 had an effect the frequency of this failure, because of the mouseout handler changes.
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
I've pushed to try and will retrigger the job in question 50+ times to see if it worked. I pushed it with the keyboard nav patch, since that was increasing the frequency of the failure it should make it easier to determine whether the fix had any effect.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4b9a71d552fc
Comment on attachment 8641242 [details] [diff] [review]
Possible patch

Patch seems to have worked, let's get it checked in!
Attachment #8641242 - Flags: review?(adw)
Attachment #8641242 - Flags: review?(adw) → review+
https://hg.mozilla.org/mozilla-central/rev/4062c2452aad
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
You need to log in before you can comment on or make changes to this bug.