[e10s] close <select> element leads to open URL

RESOLVED FIXED in Firefox 41

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: blinky, Assigned: Neil Deakin)

Tracking

(Blocks: 2 bugs, {regression})

42 Branch
mozilla42
x86_64
Windows 7
regression
Points:
1
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox41 fixed, firefox42 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Steps to reproduce:

1. Go to https://dl.dropboxusercontent.com/u/95157096/85f61cf7/qe0w9gfq7x.html.
2. Open the <select> element.
3. Click on the <select> element to close.


Actual results:

Close <select> element leads to open URL.
(Reporter)

Updated

3 years ago
Summary: Close <select> element leads to open URL → [e10s] Close <select> element leads to open URL

Updated

3 years ago
Blocks: 1149745
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Ever confirmed: true

Updated

3 years ago
Blocks: 653064, 1154677
Flags: needinfo?(enndeakin)
Keywords: regression
(Reporter)

Updated

3 years ago
Summary: [e10s] Close <select> element leads to open URL → [e10s] close <select> element leads to open URL
(Assignee)

Comment 2

3 years ago
I'll look at this.
Assignee: nobody → enndeakin
Flags: needinfo?(enndeakin)
(Assignee)

Comment 3

3 years ago
Created attachment 8638695 [details] [diff] [review]
Fix silliness

Wrong kind of brackets.
Attachment #8638695 - Flags: review?(felipc)
(Assignee)

Updated

3 years ago
Points: --- → 1
Attachment #8638695 - Flags: review?(felipc) → review+
(Assignee)

Comment 4

3 years ago
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/effb4125322895c0c7f01d8bfe7ecb99f5c3a502
changeset:  effb4125322895c0c7f01d8bfe7ecb99f5c3a502
user:       Neil Deakin <neil@mozilla.com>
date:       Mon Jul 27 07:33:55 2015 -0400
description:
Bug 1186398, perform correct check when comparing if the select value has changed, r=felipe
https://hg.mozilla.org/mozilla-central/rev/effb41253228
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla42

Comment 6

3 years ago
Could this be uplifted to Aurora as well? Assuming I haven't made a mistake, Bug 1149745 landed during the 41 timeframe.

Sorry for not filling out the uplift template myself. The change doesn't look risky, but I'm too unfamiliar with the code to be confident.

Thanks!
status-firefox41: --- → affected
Flags: needinfo?(enndeakin)
(Assignee)

Comment 7

3 years ago
Comment on attachment 8638695 [details] [diff] [review]
Fix silliness

Approval Request Comment
[Feature/regressing bug #]: regression from bug 1149745
[User impact if declined]: the change event on <select> elements fires at the wrong time, and will cause site compatibility issues. e10s only issue.
[Describe test coverage new/current, TreeHerder]: tested on try and has tests in patch
[Risks and why]: caused by minor typo, no real risk
[String/UUID change made/needed]: none
Flags: needinfo?(enndeakin)
Attachment #8638695 - Flags: approval-mozilla-aurora?

Comment 8

3 years ago
Comment on attachment 8638695 [details] [diff] [review]
Fix silliness

Simple change + a test, seems safe to uplift to Aurora.
Attachment #8638695 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Updated

3 years ago
tracking-e10s: ? → ---
You need to log in before you can comment on or make changes to this bug.