Remove/hide localhost references in the address-bar

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: bkmunar)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

Attachments

(1 attachment)

PR
47 bytes, text/x-github-pull-request
bnicholson
: review+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
This is coming up on ios-feedback, where we are showing the local server address more often than we want (for reasons we should figure out here).

Kill it.

https://groups.google.com/a/mozilla.com/d/msgid/ios-feedback/DD64D66E-2EF5-4A7E-A1EC-592854798275%40gmail.com
(Reporter)

Comment 1

3 years ago
I see the localhost:port/errors/undefined error on tab restore where one of the tabs is about:home
(Assignee)

Comment 2

3 years ago
I think I fixed this already? I'm reproducing it and it's not showing up for me?
(Assignee)

Comment 3

3 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=1183806 <-- this is the bug; are you running a current build and triggering the sessionrestore?
(Reporter)

Comment 4

3 years ago
I'm running master, ios-feedback post is on build #25.
(Assignee)

Comment 5

3 years ago
Does it still happen?
(Assignee)

Comment 6

3 years ago
*on master?
(Assignee)

Comment 7

3 years ago
Any updates on this?
(Reporter)

Comment 8

3 years ago
Yes, this is visible on tab restoration (at least for me) when an error page is in focus.

E.g, visit a non existent page (i.e, http://192.168.1.999), close browser re-open browser, see localhost error address
(Assignee)

Comment 9

3 years ago
@Aaron, got it, ill get on it
(Assignee)

Updated

3 years ago
Assignee: nobody → bmunar
(Assignee)

Comment 10

3 years ago
Created attachment 8638764 [details] [review]
PR

LOL
Attachment #8638764 - Flags: review?(bnicholson)
Comment on attachment 8638764 [details] [review]
PR

Since you don't have any description for your fix, I'm guessing what's happening is that decodeURL is returning "localhost:port/errors/undefined", which we're returning? If that's the case, we should fix decodeURL to not return that in the first place, rather than trying band-aid the code that uses the bad result.
Attachment #8638764 - Flags: review?(bnicholson) → review-
(Assignee)

Comment 12

3 years ago
Comment on attachment 8638764 [details] [review]
PR

smiley crab
Attachment #8638764 - Flags: review- → review?(bnicholson)
Attachment #8638764 - Flags: review?(bnicholson) → review+
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
tracking-fxios: ? → +
You need to log in before you can comment on or make changes to this bug.