B2G Installer Addon: Fix workflow issues

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
3 years ago
9 months ago

People

(Reporter: hobinjk, Assigned: hobinjk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Having the console open is a prerequisite of using the B2G Installer because it otherwise doesn't report errors. Errors should be reported into the main UI.

Updated

3 years ago
Assignee: nobody → hobinjk
(Assignee)

Comment 1

3 years ago
Created attachment 8637457 [details] [review]
Github PR
Attachment #8637457 - Flags: review?(lissyx+mozillians)
Comment on attachment 8637457 [details] [review]
Github PR

We cannot take everything from this, specifically since we have UX pending on this (specs improved), but there are some good fixes insides. Might be worth to just get them for now. Error reporting is deficient for now but on purpose :).

Please also make sure we do not reject() with string directly but with real and consistent error codes so that we can later work on proper UI level error reporting.
Attachment #8637457 - Flags: review?(lissyx+mozillians)
Flags: needinfo?(dale)
Full agreed, I havent a lot for error reporting on the new UX, but it certainly needs it, these look like good improvements
Flags: needinfo?(dale)

Comment 4

9 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.