crash in mozilla::MediaFormatReader::AsyncReadMetadata()

RESOLVED WORKSFORME

Status

()

defect
P2
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: onelson, Unassigned)

Tracking

(Blocks 1 bug, {crash})

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master affected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-438c8d97-54a7-4010-acfc-4c4bc2150722.
=============================================================

After observing bug 1186572, letting the phone idle and display off will wake the phone to this crash report after completing the rest of the FTU

Repro Steps [from bug 1186572]:
1) Update a Aries to 20150722124026
2) Progress through FTU through to screen before tutorial.
3) Hit 'Next' to enter tutorial and quickly skip the first page before animated image loads.
4) Advance to next page and return to previous through tutorial observing images
5) Observe no animated tutorial
6) Let phone timeout
7) Wake phone, finish tutorial

Results:
Tutorial Finishes with a crash report


Environment Variables:
----------------------------
Device: Flame 2.5
BuildID: 20150722010204
Gaia: 84c3bf622e211046d905803b34de5d331761f22d
Gecko: 8e5c888d0d89
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
----------------------------
Repro Rate: 4/4
Possibly a dupe or root-cause of bug 1186572?
See Also: → 1186572
Component: Gaia::First Time Experience → Audio/Video
Product: Firefox OS → Core
See Also: → 1192748
Blocks: MSE
OS: Android → Gonk (Firefox OS)

Comment 2

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Keywords: qawanted
blocking-b2g: 2.5? → 2.5+

Updated

4 years ago
Priority: -- → P2
Hardware: Unspecified → ARM
Hi, all,
After applying the changeset of the bug1192748, I can't reproduce this issue.
For more complete testing, I would like to request qa-wanted to verify whether the issue can be solved by bug1192748.
Component: Audio/Video → Audio/Video: Playback
Depends on: 1192748
I think the bug1201969 have already solved this issue.
Could any QA help to verify it? 
Thanks!

Updated

4 years ago
See Also: → 1201969
Following the repro steps for this issue result in the crash bug 1204622.  The regression window for that bug indicates the fix for bug 1201969 as the culprit, so it appears that verification for this bug is currently blocked, and that we may have switched one crash for another.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150915141659
Gaia: d2e5c49440bf8410ae747b15c0dd11c54053ef3e
Gecko: 5d61714cf5c3ec2440e9491ba30893ac37ca06c2
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
According to the comment5, this bug doesn't exist and we already have another bug to handle the crash.
We should close this issue.

---

Reopen it if this issue happen again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 1192748
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.