Closed Bug 1186830 Opened 6 years ago Closed 6 years ago

Firefox fails to redirect to URL loaded

Categories

(Web Compatibility :: Desktop, defect)

Firefox 39
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1196882

People

(Reporter: spider_70, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150720220238

Steps to reproduce:

i open a attachment from this site
www.drwindows.de/attachment.php?attachmentid=32069&stc=1&d=1332258871
www.drwindows.de/attachment.php?attachmentid=50940d1322293507


Actual results:

open in a blank page.


Expected results:

the attachment should open, IE and Chrome works fine,
Firefox 38.0.5 as well
Firefox 39 don't work
http://www.drwindows.de/attachment.php?attachmentid=32069&stc=1&d=1332258871
should redirect to
http://www.drwindows.de/attachments/32069-clickalender-jahresplaner-terminplaner-ck_sg05.png

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=80431d4fd0da&tochange=bb35d1b73634

My guess is the suspected bug is bug 237623.
Blocks: 237623
Component: Untriaged → Networking: HTTP
Flags: needinfo?(daniel)
Keywords: regression
Product: Firefox → Core
Summary: attachmentid → Firefox fails to redirect to URL loaded
pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fc7621347ee6&tochange=51a3652ce2ec


Regressed by:
51a3652ce2ec	Daniel Stenberg — Bug 237623 - introduce "soft" checks for HTTP framing errors, r=mcmanus
Status: UNCONFIRMED → NEW
Ever confirmed: true
WORKAROUND: 
network.http.enforce-framing.soft = false
This server is clearly dead stupid:

$ curl  "http://www.drwindows.de/attachment.php?attachmentid=32069&stc=1&d=1332258871"
curl: (18) transfer closed with 141175 bytes remaining to read

Meaning that the 301 response is returned claiming to have "Content-Length: 141175" but the connection is still closed after the headers without sending a single byte of body...
Flags: needinfo?(daniel)
We probably don't need to fail such a response when it is a redirect.
I agree that it the check probably can be skipped safely for all 3xx redirects, but it means yet another kludgey exception to the checks.
this doesn't seem to be running rampant, so let's see if TE can get the site fixed.
Component: Networking: HTTP → Desktop
Product: Core → Tech Evangelism
Version: 39 Branch → Firefox 39
Another example of non-working redirect seems to be the "Meine Konten" button on "https://www.rabodirect.de/" that opens "https://www.rabodirect.de/includes/redirects.aspx?type=anmelden". Middle-clicking it to open in a new tab works (but isn't the desired way to do it), left-clicking it to open the pop-up (same URL, just in a "special" window) leaves an empty page that Firebug identifies as a 301 Moved Permanently redirect.
Setting "network.http.enforce-framing.soft = false" does not help in any way.
(In reply to wormdotnospam from comment #8)
> Another example of non-working redirect seems to be the "Meine Konten"
> button on "https://www.rabodirect.de/" that opens
> "https://www.rabodirect.de/includes/redirects.aspx?type=anmelden".
> Middle-clicking it to open in a new tab works (but isn't the desired way to
> do it), left-clicking it to open the pop-up (same URL, just in a "special"
> window) leaves an empty page that Firebug identifies as a 301 Moved
> Permanently redirect.
> Setting "network.http.enforce-framing.soft = false" does not help in any way.

It works for me, left clicking on the link opens the page in a pop-up, same from the context menu in a new tab/window. Try in safe mode or with a fresh profile.
(In reply to Loic from comment #9)

> It works for me, left clicking on the link opens the page in a pop-up, same
> from the context menu in a new tab/window. Try in safe mode or with a fresh
> profile.

Ah sorry, should have researched a bit more before. It seems Ghostery is causing that. (Though I don't really see how that would be related to its usual work, which is why I didn't expoect it to be the cause in the first place.)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196882
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.