Intermittent browser_devices_get_user_media_in_frame.js | application crashed [@ libpixman-1.so.0.24.4 + 0x4a9f0]

RESOLVED DUPLICATE of bug 1194397

Status

()

defect
RESOLVED DUPLICATE of bug 1194397
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected)

Details

Reporter

Description

4 years ago
10:17:26 INFO - 468 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | webRTC-shareDevices notification shown
10:17:26 INFO - 469 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | notification panel open
10:17:26 INFO - 470 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | notification panel populated
10:17:26 INFO - 471 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | expected notification getUserMedia:request
10:17:26 INFO - 472 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | microphone selector visible
10:17:26 INFO - 473 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | camera selector visible
10:17:26 INFO - 474 INFO expecting a chrome://browser/content/webrtcIndicator.xul window
10:17:26 INFO - 475 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | received ok
10:17:26 INFO - 476 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | expected notification getUserMedia:response:allow
10:17:26 INFO - 477 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | expected notification recording-device-events
10:17:26 INFO - 478 INFO TEST-PASS | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | expected camera and microphone to be shared
10:17:26 WARNING - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | application terminated with exit code 11
10:17:26 INFO - runtests.py | Application ran for: 0:08:26.685144
10:17:26 INFO - zombiecheck | Reading PID log: /tmp/tmpT9ati2pidlog
10:17:35 INFO - mozcrash Saved minidump as /builds/slave/test/build/blobber_upload_dir/03017f39-3853-9e4e-3256bc40-05225511.dmp
10:17:35 INFO - mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/03017f39-3853-9e4e-3256bc40-05225511.extra
10:17:35 WARNING - PROCESS-CRASH | browser/base/content/test/general/browser_devices_get_user_media_in_frame.js | application crashed [@ libpixman-1.so.0.24.4 + 0x4a9f0]
10:17:35 INFO - Crash dump filename: /tmp/tmpBI8eT3.mozrunner/minidumps/03017f39-3853-9e4e-3256bc40-05225511.dmp
10:17:35 INFO - Operating system: Linux
10:17:35 INFO - 0.0.0 Linux 3.2.0-76-generic #111-Ubuntu SMP Tue Jan 13 22:16:09 UTC 2015 x86_64
10:17:35 INFO - CPU: amd64
10:17:35 INFO - family 6 model 62 stepping 4
10:17:35 INFO - 1 CPU
10:17:35 INFO - Crash reason: SIGSEGV
10:17:35 INFO - Crash address: 0x0
10:17:35 INFO - Thread 0 (crashed)
10:17:35 INFO - 0 libpixman-1.so.0.24.4 + 0x4a9f0
10:17:35 INFO - rbx = 0x00007f52e3daad08 r12 = 0x0000000000000000
10:17:35 INFO - r13 = 0x0000000000000000 r14 = 0x00007f52e0bd72a0
10:17:35 INFO - r15 = 0x0000000000000000 rip = 0x00007f53376509f0
10:17:35 INFO - rsp = 0x00007fff5622f8f0 rbp = 0x00007f52e3dd60a8
10:17:35 INFO - Found by: given as instruction pointer in context
10:17:35 INFO - 1 libcairo.so.2.11000.2 + 0x3fbc4
10:17:35 INFO - rip = 0x00007f5339b0fbc5 rsp = 0x00007fff5622f910
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 2 libgdk-3.so.0.400.1 + 0x2cd76
10:17:35 INFO - rip = 0x00007f533ad3ed77 rsp = 0x00007fff5622f930
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 3 firefox!je_malloc [jemalloc.c:69193199b90f : 6164 + 0x7]
10:17:35 INFO - rip = 0x000000000041b51f rsp = 0x00007fff5622f940
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 4 libgdk-3.so.0.400.1 + 0x2d085
10:17:35 INFO - rip = 0x00007f533ad3f086 rsp = 0x00007fff5622f9a0
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 5 libxul.so!nsWindow::SetHasMappedToplevel(bool) [nsWindow.cpp:69193199b90f : 3927 + 0x8]
10:17:35 INFO - rip = 0x00007f53323198aa rsp = 0x00007fff5622f9e0
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 6 libxul.so!nsWindow::SetHasMappedToplevel(bool) [nsWindow.cpp:69193199b90f : 3941 + 0xa]
10:17:35 INFO - rip = 0x00007f53323198fd rsp = 0x00007fff5622fa10
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 7 libxul.so!window_state_event_cb [nsWindow.cpp:69193199b90f : 5573 + 0x16]
10:17:35 INFO - rip = 0x00007f533231bbd1 rsp = 0x00007fff5622fa40
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 8 libxul.so!nsWindow::OnWindowStateEvent(_GtkWidget*, _GdkEventWindowState*) [nsWindow.cpp:69193199b90f : 3185 + 0x7]
10:17:35 INFO - rip = 0x00007f533231bb91 rsp = 0x00007fff5622fa60
10:17:35 INFO - Found by: stack scanning
10:17:35 INFO - 9 0x7f52ea7eb07f
10:17:35 INFO - rbx = 0x00007fff5622fc70 r12 = 0x00007f52ebf06120
10:17:35 INFO - r13 = 0x00007fff5622fc00 rip = 0x00007f52ea7eb080
10:17:35 INFO - rsp = 0x00007fff5622fa68 rbp = 0x00007f533231bb91
10:17:35 INFO - Found by: call frame info
10:17:35 INFO - 10 libgtk-3.so.0.400.1 + 0x17b237
10:17:35 INFO - rip = 0x00007f533b10b238 rsp = 0x00007fff5622fa70
10:17:35 INFO - Found by: stack scanning
Comment hidden (Legacy TBPL/Treeherder Robot)
Looks similar to some other gdk (IIRC some invalidate_rect) crashes I've seen in the last few months (this call was gdk_window_invalidate_rect(mGdkWindow, nullptr, false)).  In any case, it's deep in windowing widget code.

If there's something we're doing that's triggering this, I'd love to know, ping me for assistance
Component: WebRTC → Widget: Gtk
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Updated

4 years ago
See Also: → 1150574
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Blocks: gtk3
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Depends on: 817712
See Also: → 1195571
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194397
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.