Video duration keeps increasing

RESOLVED DUPLICATE of bug 1180214

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1180214
2 years ago
2 years ago

People

(Reporter: overholt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
George made me watch https://www.youtube.com/watch?t=163&v=joKVyKf0obU and the duration of the video kept increasing after starting at what I assume is the correct length, ~1 h.  The duration seemed to stop increasing at 4 h 51 min.

I'm running nightly on Fedora 21 and these packages may be of interest:

$ rpm -qa | grep ffmpeg
gstreamer-ffmpeg-0.10.13-15.fc21.x86_64
ffmpeg-libs-2.4.10-1.fc21.x86_64

$ rpm -qa | grep gstreamer
gstreamer1-plugins-good-1.4.5-2.fc21.x86_64
gstreamer-0.10.36-11.fc21.i686
gstreamer1-libav-1.4.5-1.fc21.x86_64
gstreamer-plugins-bad-free-0.10.23-24.fc21.x86_64
gstreamer-plugins-base-0.10.36-12.fc21.x86_64
gstreamer1-plugins-bad-free-1.4.5-2.fc21.x86_64
gstreamer1-plugins-base-1.4.5-1.fc21.i686
gstreamer1-1.4.5-1.fc21.x86_64
gstreamer-plugins-good-0.10.31-13.fc21.x86_64
gstreamer1-plugins-bad-freeworld-1.4.5-2.fc21.x86_64
gstreamer-plugins-base-devel-0.10.36-12.fc21.x86_64
gstreamer-0.10.36-11.fc21.x86_64
gstreamer-devel-0.10.36-11.fc21.x86_64
gstreamer1-1.4.5-1.fc21.i686
gstreamer1-plugins-base-1.4.5-1.fc21.x86_64
gstreamer-plugins-base-0.10.36-12.fc21.i686
gstreamer-plugins-espeak-0.4.0-5.fc21.x86_64
libnice-gstreamer1-0.1.7-1.fc21.x86_64
PackageKit-gstreamer-plugin-1.0.6-1.fc21.x86_64
gstreamer1-plugins-ugly-1.4.5-1.fc21.x86_64
gstreamer-plugins-ugly-0.10.19-18.fc21.x86_64
gstreamer-ffmpeg-0.10.13-15.fc21.x86_64
gstreamer-tools-0.10.36-11.fc21.x86_64
For what it's worth, I can reproduce this as well on Fedora 21, but not on Windows or OS X. It only happens with the HTML5 youtube player.
(Reporter)

Comment 2

2 years ago
Oh yeah, I forgot to say that I'm using the HTML player (I don't have flash installed).

Comment 3

2 years ago
I reported a similar problem a few years ago: Bug 948155.  The URL in that bug is no longer valid, but I still have the file saved locally.
(Reporter)

Comment 4

2 years ago
(In reply to Trevor Rowbotham from comment #3)
> I reported a similar problem a few years ago: Bug 948155.  The URL in that
> bug is no longer valid, but I still have the file saved locally.

Thanks, I didn't see that while filing this bug.  I'm not sure it's the same thing, though, as my issues appears to be Linux-specific and yours seems Windows-specific.

Let's leave them unduped for now but that's easily fixed if I'm wrong.
My guess would be an issue in the gstreamer-0.10 backend. Bug 948155 relates to MP3 which is different enough.

Comment 6

2 years ago
I'm having the same issue here, on Arch Linux using Firefox Beta. It doesn't look like a backend issue to me, since it only appeared on the 41 betas (I double-checked by downgrading again). It happens with all HTML5 videos, not only Youtube, and I can confirm it doesn't happen on Windows.
likely a dupe of bug 1180214
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1180214
You need to log in before you can comment on or make changes to this bug.