Problems with elements, having display:inline-block

RESOLVED DUPLICATE of bug 9458

Status

()

defect
--
trivial
RESOLVED DUPLICATE of bug 9458
18 years ago
17 years ago

People

(Reporter: alexander.grimalovsky, Assigned: attinasi)

Tracking

({css3})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Reporter

Description

18 years ago
It seems, there is some problems with handling elements with 'display:
inline-block' style assigned. Especially if they have also 'width' style assigned. 

 I prepare small testcase to display all cases of using these styles together.
Reporter

Comment 1

18 years ago
I'll have to look at the spec to see if that behaviour is incorrect or just
unexpected, it's a little early in the morning and I'm not fully awake. 

Basically, whenever you have white-space: nowrap; it renders span2 behind span1
(try selecting the second test and pasting it into notepad)

bbl.
OS: Windows 2000 → All
Hardware: PC → All
Summary: Problems with elements, having display:inline-block → Problems with elements, having display:inline-block
ok, I think I see the problem with your example. There is no 'inline-block'
value for the display property, just 'inline' and 'block'. Changing this to
'block' is what you're looking for I believe.
reporter, is this what you expected it to look like? if so, this bug can be
resolved as invalid.
Reporter

Comment 5

18 years ago
 Actually no. I expect to see 2 spans, 200px width each to be placed into one
line.  Please refer comments to bug 10052
(http://bugzilla.mozilla.org/show_bug.cgi?id=10052#c3) - i get information for
this testcase from this comment.
There is no 'inline-block' in CSS2, but it's proposed for CSS3, and Mozilla
parses it, although it doesn't support it well and we probably shouldn't be
parsing it.
Adding css3 keyword, dropping priority for now pending finalization of spec.
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css3
Target Milestone: --- → Future
'inline-block' was disabled with the fix for bug 3935.
i see. so i'd like to see this bug duped against Bug 9458 ([RFE] Implement
inline-block in layout) since a correct implementation would imho be the
solution to this one here. but i guess this won't happen, until css3 is a little
more advanced. if anyone resists, please reopen.

*** This bug has been marked as a duplicate of 9458 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.