Titlebar overlaps tab bar with GTK3

RESOLVED DUPLICATE of bug 1195002

Status

()

--
major
RESOLVED DUPLICATE of bug 1195002
3 years ago
3 years ago

People

(Reporter: rolandixor, Unassigned)

Tracking

42 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150724030210

Steps to reproduce:

Simply upgraded to the newest nightly build.


Actual results:

The titlebar is not drawn correctly, but overlaps with the tab bar. As a result the window cannot be resized or moved using the title bar or borders.


Expected results:

The two should be integrated correctly.
(Reporter)

Updated

3 years ago
Blocks: 627699
Severity: normal → major
Component: Untriaged → Toolbars and Customization
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
Created attachment 8647359 [details]
1187485 – Titlebar overlaps tab bar with GTK3 - Nightly_129.png

This is what it looks like. It's totally broken. There is no titlebar or window border.
I have the same issue on elementary OS (with pantheon as DE), the titlebar in non-maximized windows is offset a bit to the bottom and to the right, so it's about over the normal toolbar. When maximized the titlebar sits at the top, but draws over the tabbar. My titlebar has buttons on both ends.

I also think the window border is missing, since I cannot see a resizing cursor in the bottom corners. Oh, and dialogs don't draw except for the titlebar.
Created attachment 8647995 [details]
Firefox Nightly on elementary OS
I get following logging messages when launching Firefox Nightly from the console:
*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

(firefox:12826): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.42.2/./gobject/gsignal.c:3410: signal name 'text-insert::system' is invalid for instance '0x7f

(firefox:12826): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.42.2/./gobject/gsignal.c:3410: signal name 'load_complete' is invalid for instance '0x7fb010aa2650' of type 'MaiAtkType1'

(firefox:12826): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.42.2/./gobject/gsignal.c:3410: signal name 'text-insert' is invalid for instance '0x7fb007de0060' of type 'MaiAtkType1'
affc8d3650' of type 'MaiAtkType1'

(firefox:12826): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.42.2/./gobject/gsignal.c:3410: signal name 'text-remove::system' is invalid for instance '0x7fb009da3290' of type 'MaiAtkType1'

Comment 5

3 years ago
I'm also having this problem!

Comment 6

3 years ago
+1 for this problem!
I know this bug was filed first thanks, but bug 1195002 has some discussion on how to fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1195002
You need to log in before you can comment on or make changes to this bug.