RFE: Add support for global events for mouse buttons above 5

RESOLVED DUPLICATE of bug 30431

Status

()

Core
Event Handling
--
enhancement
RESOLVED DUPLICATE of bug 30431
16 years ago
15 years ago

People

(Reporter: Sam Rowe, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020106
BuildID:    2002010606

I'd like to be able to map button6 to Moz' "Back" and Button7 to "Forward"
globally (not just on one page.)

Comment 1

16 years ago
The back/forward feature is covered by bug 30431

Updated

16 years ago
QA Contact: madhur → rakeshmishra
INVALID until it's possible to use those buttons on Linux at all
(Reporter)

Comment 3

16 years ago
I use those buttons in Linux every single day.

http://www.deadman.org/X/xbuttons.html

Comment 4

16 years ago
Mice with more than five buttons are supported (at least on BSD and Linux
systems) with properly configured XFree86 since version 4.1. It'd be nice to add
a back/forward buttons to mozilla (in latest kde the support is included for
example).

Comment 5

16 years ago
Confirming this is a 30431 bug duplicate.

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 30431 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.