If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't interact with firefox when screen filter is active

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kbaby, Assigned: mcomella)

Tracking

42 Branch
All
Android
Points:
---

Firefox Tracking Flags

(fennec42+)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150722030205

Steps to reproduce:

Have a screen filter (e.g twillight, dimmer, etc) active.


Actual results:

Can't interact at all; can't scroll, click links on webpages, or use the urlbar/ newtab button/ hamburger menu.


Expected results:

Be able to use firefox normally.
Mike: I wonder if this is outfall from adding filterTouchesWhenObscured?

I think I noticed something similar when a "heads-up notification" is shown by Hangouts. But I wanted to do some more testing before filing.
Flags: needinfo?(michael.l.comella)
I'm seeing this with twilight installed (which also explains why I tend to see it at the end of the day) and the time frame coresponds with the landing of bug 1147265.

mcomella, I think we need a back out
Assignee: nobody → michael.l.comella
tracking-fennec: --- → ?
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> I'm seeing this with twilight installed (which also explains why I tend to
> see it at the end of the day) and the time frame coresponds with the landing
> of bug 1147265.
> 
> mcomella, I think we need a back out

I agree. I would also like to know how other apps, that use filterTouchesWhenObscured are effected by things like Twilight.
Blocks: 1147265
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
Duplicate of this bug: 1187704
(In reply to Mark Finkle (:mfinkle) from comment #3)
> (In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> > I'm seeing this with twilight installed (which also explains why I tend to
> > see it at the end of the day) and the time frame coresponds with the landing
> > of bug 1147265.
> > 
> > mcomella, I think we need a back out
> 
> I agree. I would also like to know how other apps, that use
> filterTouchesWhenObscured are effected by things like Twilight.

I think I just found out. I haven't been able to update nightly or install aurora for a while. Apparently the system installer uses filterTouchesWhenObscured because disabling twilight just allowed me to click the install button for the first time in a month or so.
So it sounds like Twilight (and other filters) would always create some level of "bustage" in Fennec, even if we did our best to limit the filterTouchesWhenObscured to only "actions" like menus and buttons.

Comment 7

2 years ago
+1
I have replicated this bug while using Lux in Nightly using Android 4.4.2

I only started having this issue around two weeks ago.
tracking-fennec: ? → 42+
Duplicate of this bug: 1189478
(Assignee)

Comment 9

2 years ago
Backout in bug 1147265 so this should be fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(michael.l.comella)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.