Closed Bug 1187616 Opened 6 years ago Closed 6 years ago

Page does not be repainted properly when toggle sidebar

Categories

(Core :: Panning and Zooming, defect)

42 Branch
Unspecified
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: alice0775, Assigned: kats)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/d3228c82badd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150725030209


Steps to reproduce:

1. Open http://www.so-net.ne.jp/
2. Open Sidebar (Ctrl+B)
3. Shrink browser window width to approx 1070px so that horizontal scrollbar appears
4. Scroll to right by drag horizontal scrollbar
5. Close Sidebar


Actual Results:
Page does not placed in center.
Scroll in vertically little bit, then Page will be in center.

Expected Results:
Page should be in center
OS: Unspecified → Windows 7
I can reproduce on any web page such as https://bugzilla.mozilla.org/show_bug.cgi?id=1187616
Thanks, I can reproduce this on OS X as well. It probably affects all platforms; and the root cause is probably the same as bug 1187373 comment 1 (we're not clamping the scroll position properly in APZ after stuff changes).
Blocks: all-aboard-apz
No longer blocks: apz-windows
OS: Windows 7 → All
See Also: → 1187373
Regression window( with force apz enabled ):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=49ae0961591e&tochange=fee45cd9a4d9

Regressed by: Bug 1178847
Blocks: 1178847
Flags: needinfo?(bugmail.mozilla)
Keywords: reproducible
Assignee: nobody → bugmail.mozilla
Flags: needinfo?(bugmail.mozilla)
The patch on bug 1187792 fixes this also.
Depends on: 1187792
Marking fixed by bug 1187792; please reopen if you still see this happening.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.