Closed Bug 1187633 Opened 5 years ago Closed 5 years ago

UX: would be nice to go back to the previous screen after tapping the back button in Bug page

Categories

(Firefox OS Graveyard :: Gaia::Bugzilla Lite, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.5+)

VERIFIED FIXED
FxOS-S5 (21Aug)
feature-b2g 2.5+

People

(Reporter: cynthiatang, Assigned: daleharvey)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Build Number: eng.worker.20150619.224059

Steps to Reproduce:
1. Navigate to the Bugzilla Lit website
2. Sign in with the test account credentials
3. Tap "Filed"
4. Choose the bug you want to view
5. Tap < (Back button)

Actual Results: 
Bugzilla Lite will go back to "Assigned" list after tapping < (Back button)

Expected Results: 
Bugzilla Lite will go back to "Filed" list after tapping < (Back button)
Summary: UX: would be nice to go back to Filed list after tapping the back button in Bug Page → UX: would be nice to go back to the previous screen after tapping the back button in Bug page
Flags: needinfo?(jsavory)
feature-b2g: --- → 2.5+
Yup, expected result is correct here. It would be best if the tabbed view could be maintained wherever possible within the app and when navigating outside the app and returning to it.
Flags: needinfo?(jsavory)
So this stores the last tab you had open on the dashboard and if you navigate to the dashboard / open it again you get the same tab.
Assignee: nobody → dale
Attachment #8644943 - Flags: review?(dietrich)
Target Milestone: --- → FxOS-S5 (21Aug)
Whiteboard: [systemsfe]
Duplicate of this bug: 1190711
Sweet cheers

https://github.com/mozilla-b2g/bzlite/commit/dc489d670c2baded6509d1175a2ce32edcda7636
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.