[gtk3] 2 valgrind errors

RESOLVED FIXED in Firefox 42

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla42
Points:
---

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=9775743&repo=try

Essentially there are 2 errors:
- write() with uninitialized bytes in fontconfig.
- invalid free with a weird backtrace.
The write in FcInit() seems unlikely to be related to application usage of the library.  Seems more likely an issue in the library, and so can be suppressed, assuming that is possible.
(Assignee)

Comment 2

3 years ago
So, with debugging symbols, this is what the FcInit() failures look like:

==9529== Syscall param write(buf) points to uninitialised byte(s)
==9529== at 0x4E4148D: ??? (in /lib64/libpthread-2.12.so)
==9529== by 0xAB1BD43: FcDirCacheWrite (fccache.c:921)
==9529== by 0xAB22CB3: FcDirCacheScan (fcdir.c:289)
==9529== by 0xAB1EB48: FcConfigAddDirList (fccfg.c:355)
==9529== by 0xAB1EDD5: FcConfigBuildFonts (fccfg.c:388)
==9529== by 0xAB27EFA: FcInitLoadConfigAndFonts (fcinit.c:106)
==9529== by 0xAB27FC4: FcInit (fcinit.c:124)
(snip)

They are reproducible by running fc-cache, so they clearly are entirely within fontconfig.

Now, running firefox shouldn't make us write the fontconfig cache ourselves, at least not in most cases, because the cache will already exist somehow. So I'm going to test pre-generating the fontconfig cache, along pango.modules and gdb-pixbuf's loaders.cache.
(Assignee)

Comment 3

3 years ago
Created attachment 8640351 [details] [diff] [review]
Create a fontconfig cache so that Firefox doesn't have to do it itself when run on build automation
Assignee: nobody → mh+mozilla
Attachment #8640351 - Flags: review?(mshal)
(Assignee)

Comment 4

3 years ago
Created attachment 8640353 [details] [diff] [review]
Don't run gst-plugin-scanner through valgrind, it only leads to irrelevant errors
Attachment #8640353 - Flags: review?(n.nethercote)
Comment on attachment 8640353 [details] [diff] [review]
Don't run gst-plugin-scanner through valgrind, it only leads to irrelevant errors

Review of attachment 8640353 [details] [diff] [review]:
-----------------------------------------------------------------

Nice comment.
Attachment #8640353 - Flags: review?(n.nethercote) → review+
Attachment #8640351 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/be94d55627f4
https://hg.mozilla.org/mozilla-central/rev/dfc1cb1c26d9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Backed out because it depends on bug 1186748, which had to be backed out.
https://hg.mozilla.org/mozilla-central/rev/a2d31912a7a9
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/207c45dd3c2e
https://hg.mozilla.org/mozilla-central/rev/695b89efecfa
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.