Part-selection of some URLs impossible

RESOLVED INVALID

Status

()

Core
Selection
--
minor
RESOLVED INVALID
17 years ago
16 years ago

People

(Reporter: John Levon, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020105
BuildID:    checkout finish: Mon Jan 7 23:15:17 GMT 2002

I cannot select the


ftp://ferret.lmh.ox.ac.uk/pub/linux/vsftpd-1.0.1.tar.gz

URL on the given page such that only :

ftp://ferret.lmh.ox.ac.uk/pub/linux/

is selected (for pasting to go to there).

I can't start from the middle (drag and drop gets enabled) and
I can't start from the start (selects all previous text)

Reproducible: Always
Steps to Reproduce:
1. try to select part of the URL from the start using the mouse
2.
3.

Actual Results:  Either goes into drag and drop, or selects all previous text on the
page too.

Expected Results:  Allowed me to select part of the URL !

Comment 1

17 years ago
You can hold Alt down while selecting to disable drag'n'drop.
(Reporter)

Comment 2

17 years ago
a) no I can't, my window manager takes Alt. (KDE2 kwin)

b) this doesn't explain the weird beginning of line behaviour
   on this particular page.

Updated

17 years ago
OS: Linux → All
Hardware: PC → All

Comment 3

17 years ago
No dups found, marking NEW.

Could it have something to do with the link being inside a <table>? If so, this
might be related to bug 54418.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
this link is in a table of 0 with.  selecting to the "left" of the link to 
start the selection snaps the selection to before the TABLE.  we cannot avoid 
this since we do want people to be able to select whole tables. exactly the 
same thing happens on IE if that means anything to whomever reads this comment.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

16 years ago
so why isn't this tech evang then ? isn't freshmeat high profile enough ?
You need to log in before you can comment on or make changes to this bug.