Janky scrolling behaviour on bhphotovideo.com

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: gw280, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

I noticed some very strange behaviour with scrolling on bhphotovideo.com. Basically, the entire content area seems offset by some amount vertically, and there is a strip of unrendered content at the bottom of the page.

The scrollbars are also broken; if you scroll up to the top of the page then the scrollbar actually goes above and beyond the top and is no longer visible.

I've attached a video showing this behaviour as it's quite hard to explain.
OK, bugzilla won't let me attach the file as it's too large, so I've uploaded it to my server here:

http://twuttur.com/bhphoto-scrolling.mov
This appears to be APZC related; disabling APZC seems to resolve the issues.
Do you have any addons installed? It almost looks like something took the content area and wrapped it in a scrollable frame, and that scrollable frame is getting scrolled.
FWIW I can't reproduce on that site on either 10.9.5 or 10.10.4 using latest Nightly.
Blocks: 1013364
No addons, no plugins, no extensions. I can reproduce this on both my 13" retina and 15" retina. It seems to only happen if the window is sized fairly large (I don't run hidpi).
I just tested this on a clean profile on build 20150728030209 and can still reproduce the issue.
I wonder if inspecting the dom when the problem happens could be helpful. Things like if the thing that scrolls the main content isn't the root scroll frame (a scrollable div), or if there is some fixed pos thing overlaying the page (there is a modal div on the page, but it's properly sized to 0 for me) could maybe cause something like this.

(I couldn't reproduce myself.)
I did some more testing. This is still 100% reproducible on both my machines, and it only seems to happen if the browser window is >1200px high. I can look further into it if you want more info.
I can definitely reproduce some weirdness on my Macbook Pro 13" Retina when the Firefox window is maximized. Firefox Nightly 42.0a1 reproduces the issues while Firefox 39 does not. I can also see some scrolling weirdness in Windows 10 when putting Firefox Nightly in full screen mode (F11).
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All
Summary: Weird scrolling behaviour on 10.10.4 on bhphotovideo.com → Weird scrolling behaviour on bhphotovideo.com
Version: unspecified → Trunk
[Tracking Requested - why for this release]: nominating to track since this should probably block APZC from riding the trains.
status-firefox42: --- → affected
tracking-firefox42: --- → ?
APZC is nightly-only for now, so it's not riding the trains yet (and therefore not tracking 42). Making this bug block the tracking bug for riding the trains.
Blocks: 1178298
No longer blocks: 1013364
status-firefox42: affected → ---
tracking-firefox42: ? → ---

Updated

3 years ago
Duplicate of this bug: 1194406
Duplicate of this bug: 1198312
Confirmed that bug 1193557 fixes most of the issues on this page. However it's still not a great user experience. If you scroll up, somewhere near the top of the page it decides to scroll back down (or at least, the compositor shows it as having scrolled down), then it corrects itself and continues scrolling up again. It only happens when you scroll fast, and it looks janky.
(In reply to David Anderson [:dvander] from comment #14)
> If you scroll up, somewhere near the
> top of the page it decides to scroll back down (or at least, the compositor
> shows it as having scrolled down), then it corrects itself and continues
> scrolling up again. It only happens when you scroll fast, and it looks janky.

I saw this behaviour once or twice while testing it just now, and it felt kind of like the page was doing a scrollTo or scrollBy causing the jump. Maybe what I'm seeing is different though.

George (and Asa and BenWa), since you guys all filed bugs for this issue, do you see any outstanding issues here that only happen with APZ enabled?
Flags: needinfo?(gwright)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #15)
> (In reply to David Anderson [:dvander] from comment #14)
> > If you scroll up, somewhere near the
> > top of the page it decides to scroll back down (or at least, the compositor
> > shows it as having scrolled down), then it corrects itself and continues
> > scrolling up again. It only happens when you scroll fast, and it looks janky.
> 
> I saw this behaviour once or twice while testing it just now, and it felt
> kind of like the page was doing a scrollTo or scrollBy causing the jump.
> Maybe what I'm seeing is different though.
> 
> George (and Asa and BenWa), since you guys all filed bugs for this issue, do
> you see any outstanding issues here that only happen with APZ enabled?

Well, it only happens on Firefox, and only with APZ enabled. I can't see that jank on other browsers.
I don't see any bugs but there's noticeable of checkerboard. I didn't see scrolling behavior that :dvander saw.
Actually... it's a bug with APZ/BasicLayers interaction I think, since this page uses a mix-blend-mode: screen which most compositors don't support. CompositorOGL does though, so it makes sense you wouldn't see this on Mac (if that's what you used).

But I just added BasicCompositor/D3D11 support for the mix-blend-mode: screen, so I guess  it's moot now.
(In reply to David Anderson [:dvander] from comment #16)
> Well, it only happens on Firefox, and only with APZ enabled. I can't see
> that jank on other browsers.

Agreed that it's still a bug. I'm just trying to determine if it should still block all-aboard-apz or if it can be moved to block apz-desktop. If it's just jank and not correctness then I would like to make it block apz-desktop instead.
I still see the weird scrolling behaviour on bhphotovideo.com on my 13" rMBP running Nightly 20150917030229. Disabling apzc causes the issue to go away.
Flags: needinfo?(gwright)
I took a look at this on George's laptop. The scrolling is janky (I can repro that) and there's a lot empty space at the bottom of the page (I can't repro that). However the issue this bug was originally filed about doesn't seem to happen any more.

Also for the record George has a MBP with a retina display but hidpi disabled so everything is teeny-tiny in real world inches, and all the textures probably have twice as many layer pixels.

Given that the remaining issues are not as severe I'm taking this off the all-aboard-apz list.
Blocks: 1013364
No longer blocks: 1178298
Summary: Weird scrolling behaviour on bhphotovideo.com → Janky scrolling behaviour on bhphotovideo.com
Name 	Firefox
Version 	47.0a1
Build ID 	20160201030241
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.