Menus should ungrab the mouse before executing any command

RESOLVED DUPLICATE of bug 30167

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 30167
17 years ago
16 years ago

People

(Reporter: Roland Mainz, Assigned: jag (Peter Annema))

Tracking

Trunk
Future
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
2002-01-07-08-trunk on Solaris and Linux:
Mozilla keeps the mouse "grabbed" while executing commands like "File/Printing",
"File/Print preview", "File/New navigator window" etc. etc.

The user cannot do anything with the mouse while it's grab'ed by the menu - this
is bad for the following cases:
- Some menu items like "File/print preview" may take a long time - sometimes
more than a minute and more (half hour if you hit the "wrong" page... =:-) ...
and the user can do _nothing_ (except killing the Zilla from a remote machine)
- If the Zilla crashes and a debugger is active the user cannot step into the
debugger window - because the pointer is still grabbed (BAD)

Solution:
Ungrab the pointer once the user has clicked on a menu item - before we execute
something which may block the Zilla for a long time...
(Assignee)

Comment 1

17 years ago
-> future
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 30167 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.