[Aries][Music]With Music playing, incoming a call, the music is not paused.

VERIFIED DUPLICATE of bug 1180618

Status

--
major
VERIFIED DUPLICATE of bug 1180618
3 years ago
3 years ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: permafail)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8640387 [details]
logcat_Aries_v2.5.txt

[1.Description]:
[Aries][v2.5][Music]Launch Music and play a song. With Music playing, incoming a call, the music is not paused, ringtone and music will play at the same time.
See attachment: logcat_Aries_v2.5.txt & Aries_v2.5_video.3gp
Found time:  11:27

[2.Testing Steps]: 
Precondition: Insert SIM card in device.
1. Launch Music app and play a song.
2. Incoming a call.

[3.Expected Result]: 
2. The music should become paused.

[4.Actual Result]: 
2. The music is not paused.

[5.Reproduction build]: 
Aries KK 2.5 (Affected):
Build ID               20150728035120
Gaia Revision          14e32276025b0310d3e89027320cf4b2a24cedfb
Gaia Date              2015-07-27 16:43:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/33dc8a83cfc0
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150728.033538
Firmware Date          Tue Jul 28 03:35:46 UTC 2015
Bootloader             s1

Flame KK 2.2 (Unaffected)
Build ID               20150728152503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/813cb3d271f0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150728.190103
Firmware Date          Tue Jul 28 19:01:14 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Flame KK 2.5 (Unaffected)
Build ID               20150728150207
Gaia Revision          862f0895f3f5a97200601542d99a152a46385a0b
Gaia Date              2015-07-28 15:30:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/833403badc41
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150728.183347
Firmware Date          Tue Jul 28 18:33:59 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
4516
(Reporter)

Comment 1

3 years ago
Created attachment 8640390 [details]
Aries_v2.5_video.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
See Also: → bug 1181982
[Blocking Requested - why for this release]:

Very bad user experience.
The audio isn't paused while phone receives a phone call.
Nominate it.
blocking-b2g: --- → 2.5?
Keywords: regression

Comment 3

3 years ago
alwu: need your input on where the issue could be. thanks!
Flags: needinfo?(alwu)

Updated

3 years ago
blocking-b2g: 2.5? → 2.5+
This issue is the same as the bug1180618.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1180618
(Reporter)

Updated

3 years ago
Whiteboard: [2.5-aries-test-run-1] → [2.5-aries-test-run-1], [2.5-aries-test-run-2]
Whiteboard: [2.5-aries-test-run-1], [2.5-aries-test-run-2] → permafail

Comment 5

3 years ago
Created attachment 8692420 [details]
verified_Aries KK v2.5.3gp

According to the STR of Comment 0, this bug has been verified as pass on latest build of Flame KK v2.5&master and Aries KK v2.5&master.

Actual results: The music is paused, ringtone is played only.
See attachment: verified_Aries KK v2.5.3gp
Reproduce rate: 0/6


Device: Flame KK v2.5 512mb (Pass)
Build ID               20151125234005
Gaia Revision          93b8bf2de3258c25199d97036c50a87667059148
Gaia Date              2015-11-25 10:29:48
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/a883c12a75da3fa58b64bcb94923b013c71f546a
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151125.224957
Firmware Date          Wed Nov 25 22:50:06 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK master 512mb (Pass)
Build ID               20151125150203
Gaia Revision          9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gaia Date              2015-11-25 06:47:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35916735b8afc5b0732e00f9aeb56bf846bba7f4
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151125.184119
Firmware Date          Wed Nov 25 18:41:33 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151125233358
Gaia Revision          93b8bf2de3258c25199d97036c50a87667059148
Gaia Date              2015-11-25 10:29:48
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/a883c12a75da3fa58b64bcb94923b013c71f546a
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151125.224212
Firmware Date          Wed Nov 25 22:42:20 UTC 2015
Bootloader             s1 

Device: Aries KK master (Pass)
Build ID               20151125021621
Gaia Revision          37250b125e0db6966875d3b37b117f6d9b76cbc0
Gaia Date              2015-11-24 16:21:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/099f695d31326c39595264c34988a0f4b7cbc698
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151125.012004
Firmware Date          Wed Nov 25 01:20:12 UTC 2015
Bootloader             s1

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.5: --- → verified
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.