[Keyboard] Keyboard click sound stops playing after 2 keys are pressed

RESOLVED DUPLICATE of bug 1183033

Status

Firefox OS
AudioChannel
RESOLVED DUPLICATE of bug 1183033
3 years ago
3 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8640788 [details]
logcat

Description:
when keyboard click sounds are turned on the clock sound will stop playing after 2 sounds are played.

Prerequisite:
Click sounds are turned on in built in keyboard settings.

Repro Steps:
1) Update a Aries to 20150729013848
2) Open messages
3) Create a new thread
4) Type in the message or to field
5) Observe audio

Actual:
The keyboard click sound stops playing after 2 letters

Expected:
It is expected that the keybaord click sound plays with every keyboard press

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150729013848
Gaia: 21256d7665f972255d198f8af81a8df4bd0e0fc4
Gecko: 2ee9895e032c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 7/10
See attached: video clip(https://youtu.be/u6Fbvo9ozus), logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150729030209
Gaia: 21256d7665f972255d198f8af81a8df4bd0e0fc4
Gecko: 2ee9895e032c
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Result:
The keyboard click sound stops playing after 2 letters
--------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150729032503
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 813cb3d271f0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The keyboard click sound plays on every button press
Blocks: 1171119
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Noticeable regression

Requesting a window, note the 7/10 repro rate.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: lixia
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame kk 2.5
Build ID               20150710163851
Gaia Revision          e4b63559eba364892867eb381c3002d6518e5d6a
Gaia Date              2015-07-10 14:29:23
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/07bcf36f5ab2
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150718.045502
Firmware Date          Sat Jul 18 04:55:13 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame kk 2.5
Build ID               20150710170452
Gaia Revision          e4b63559eba364892867eb381c3002d6518e5d6a
Gaia Date              2015-07-10 14:29:23
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/675ea719b91c
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150717.211455
Firmware Date          Fri Jul 17 21:15:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro
Gaia Revision          e4b63559eba364892867eb381c3002d6518e5d6a
Gecko Revision         07bcf36f5ab2

First Broken Gecko & Last Working Gaia - issue DOES repro
Gaia Revision          e4b63559eba364892867eb381c3002d6518e5d6a
Gecko Revision         675ea719b91c

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=07bcf36f5ab2&tochange=675ea719b91c


Possibly caused by Bug 1113086.
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Evan, is this already under your watch?
Blocks: 1113086
Flags: needinfo?(evan)
b+ for regression.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Keyboard → Gaia::System::Audio Mgmt

Comment 6

3 years ago
Tim, it is just a gecko bug and a duplicate of bug 1183033.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(evan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1183033

Updated

3 years ago
Component: Gaia::System::Audio Mgmt → AudioChannel
You need to log in before you can comment on or make changes to this bug.