New startup terminalspew: "WARNING: the property getUserMedia.sharingMenuMicrophoneApplication already exists : file xpcom/ds/nsPersistentProperties.cpp, line 532"

RESOLVED FIXED in Firefox 42

Status

()

P1
normal
Rank:
10
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dholbert, Assigned: padenot)

Tracking

Trunk
mozilla42
Points:
---

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
New startup terminalspew, introduced in the last few days I think (in debug builds):
{
[21627] WARNING: the property getUserMedia.sharingMenuMicrophoneApplication already exists
: file /scratch/work/builds/mozilla-inbound/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 532
[21627] WARNING: the property getUserMedia.sharingMenuMicrophoneScreen already exists
: file /scratch/work/builds/mozilla-inbound/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 532
[21627] WARNING: the property getUserMedia.sharingMenuMicrophoneWindow already exists
: file /scratch/work/builds/mozilla-inbound/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 532
[21627] WARNING: the property getUserMedia.sharingMenuMicrophoneBrowser already exists
: file /scratch/work/builds/mozilla-inbound/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 532
}
(Reporter)

Comment 1

3 years ago
Looks like this is telling us that we have two values for this string property in browser.properties. In particular:
> 667 getUserMedia.sharingMenuMicrophoneScreen = %S (microphone and screen)
[...]
> 671 getUserMedia.sharingMenuMicrophoneScreen = %S (tab audio and screen)
http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties

The latter line was added recently in http://hg.mozilla.org/mozilla-central/rev/235175205cde for bug 1156472.
Blocks: 1156472
Flags: needinfo?(padenot)
(Reporter)

Comment 2

3 years ago
(In reply to Daniel Holbert [:dholbert] from comment #1)
> Looks like this is telling us that we have two values for this string
> property in browser.properties.

Er, for multiple strings (not just one). I hadn't noticed, but the warnings are all slightly different -- they're for:
 sharingMenuMicrophoneApplication
 sharingMenuMicrophoneScreen
 sharingMenuMicrophoneWindow
 sharingMenuMicrophoneBrowser
all of which have duplicate definitions.

Paul, can you clean this up & pick whichever value is correct for these strings?
(Assignee)

Updated

3 years ago
Assignee: nobody → padenot
Flags: needinfo?(padenot)
Duplicate of this bug: 1190101
(Assignee)

Comment 4

3 years ago
Created attachment 8642278 [details] [diff] [review]
Put proper id for the audio capture strings. r=

This should do it.
Attachment #8642278 - Flags: review?(florian)
Comment on attachment 8642278 [details] [diff] [review]
Put proper id for the audio capture strings. r=

Please also update the list of strings in the localization note at http://hg.mozilla.org/mozilla-central/file/32712cd01159/browser/locales/en-US/chrome/browser/browser.properties#l619
Attachment #8642278 - Flags: review?(florian) → review+

Updated

3 years ago
backlog: --- → webRTC+
Rank: 10
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/0f3c55093831
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.