The default bug view has changed. See this FAQ.

[dogfood] When Name or Address of a recipient includes 8-bit characters address is incorrectly formed

VERIFIED FIXED in M11

Status

MailNews Core
MIME
P3
major
VERIFIED FIXED
18 years ago
2 months ago

People

(Reporter: Katsuhiko Momoi, Assigned: jefft)

Tracking

Trunk
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
** Observed with 8/13/99 Win32 build **

This problem was found while trying to verify Bug 10419.

I sent a message to this type of address:

Måleviçh <momoi@netscape.com>

This never got through SMTP server and got bounced with an error
msg:

-----
Each of the following recipients was rejected by a remote mail server.
The reasons given by the server are included to help you determine why
each recipient was rejected.

    Recipient: <"="@netscape.com>
    Reason:    <"="@netscape.com>... User unknown
-----

Looking at the source of the bounced message, you can see why
this occurred:

--===========================_ _= 801086(24804+6684808)
Content-Type: message/delivery-status
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

Reporting-MTA: dns; dredd.mcom.com
Received-From-MTA:dns; iqax2 (208.12.36.168)
Arrival-Date: Fri, 13 Aug 1999 19:17:14 -0700

--===========================_ _= 801086(24804+6684808)
Content-Type: message/rfc822
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

Return-Path: <iqax2>
Received: from iqax2 ([208.12.36.168]) by dredd.mcom.com
          (Netscape Messaging Server 4.1) with ESMTP id FGFNOQ00.D09 for
          <"=">; Fri, 13 Aug 1999 19:17:14 -0700
Message-ID: <37B4D34D.7000502@nsmail-2.mcom.com>
Date: Fri, 13 Aug 1999 19:24:13 -0700
From: iqax2@nsmail-2.mcom.com
Organization: Netscape.com
User-Agent: Mozilla 5.0 [en] (Win32; I)
X-Accept-Language: en
MIME-Version: 1.0
To: "=?iso-8859-1?Q?M=E5levi=E7h?= 1" <momoi8@kaze.mcom.com>,"
        =?iso-8859-1?Q?M=E5levi=E7h?= 2" <momoi@netscape.com>,"
        =?iso-8859-1?Q?M=E5levi=E7h?= 3" <momoi8@polyglot.mcom.com>,"
        =?iso-8859-1?Q?M=E5levi=E7h?= 4" <iqax2@netscape.com>
Subject: =?iso-8859-1?Q?M=E5levi=E7h?=
Content-Type: text/html; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable
------------------------------------------------------------

Some items of note:

1. We are quoting an encoded-word. This should not be done.
2. But otherwise, the structure seems to be OK.
   It is mysterious that the server could not handle this.

In any case the format "8-bit_name <ok@netscape.com>" should
not cause any trouble with our servers and it does not
when we use 4.7.
(Reporter)

Updated

18 years ago
Summary: When Name of a recipient includes 8-bit characters address is incorrectly formed → When Name or Address of a recipient includes 8-bit characters address is incorrectly formed
(Reporter)

Comment 1

18 years ago
It turns out that 8bit_id@netscape.com type of address without the
real name also causes the same problem. Accordingly I modified the
summary slightly. (See Bug 5328)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Updated

18 years ago
Assignee: rhp → jefft
Status: ASSIGNED → NEW

Comment 2

18 years ago
B1 stopper. Reassigning to jefft

Comment 3

18 years ago
Kat, i guess it's a DUP of bug #10294.
(Reporter)

Comment 4

18 years ago
No. This is not a duplicate of Bug 10294. We should keep these
two separate.
(Reporter)

Comment 5

18 years ago
However, we should do regression check next week to see if the
problem is still there.

Comment 6

18 years ago
Jeff's on vacation; moving his M10 bugs to M11
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 7

18 years ago
Adding lyecies@netscape.com to cc list.

Updated

18 years ago
Blocks: 12907

Comment 8

18 years ago
This is now easier to reproduce by using address book.
Create an ab entry name contains 8 bit characters (e.g. á alt+0225) then
"NewMsg" button from address book.

Updated

18 years ago
Blocks: 11091

Comment 9

18 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)

Updated

18 years ago
Summary: When Name or Address of a recipient includes 8-bit characters address is incorrectly formed → [dogfood] When Name or Address of a recipient includes 8-bit characters address is incorrectly formed

Updated

18 years ago
Whiteboard: [PDT+]
(Assignee)

Comment 10

18 years ago
Couple problems found here: 1) name part of an address shouldn't be requoted
which violate the rfc822 spec - msg_parse_Header_addresses(); for example
ÉéÇÅÆÂâ <qatest21@netscape.com> shouldn't be requoted with
"ÉéÇÅÆÂâ" <qatest21@netscape.com> 2) nsSmtpUrl->m_toPart is wrongly initialized
with base class GetFileName() when the address is an encoded word. For 1) I kind
of have a solution. For 2) I don't at the moment.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

18 years ago
Fix checked in. nsMsgHeaderParser.cpp & nsSmtpUrl.cpp modified.

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 12

18 years ago
changing QA assigned to pmock@netscape.com

Updated

18 years ago
QA Contact: pmock → momoi
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

18 years ago
** Checked with 11/9/99 Win32 build (1999110911) **

We had 2 problems:

1. Address was mal-formed when the Addressee name contained 8-bit characters.
2. Encoded wordw were quoted.

Both of these problems are now gone with the above build. I tried
the original problem address as well as several other types which
contained 8-bit characters in the names. They all worked OK and
mail was delivered properly.

Marking if verified/fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.