Closed Bug 1189272 Opened 6 years ago Closed 6 years ago

Menu should open over overflow rather than below

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1269774

People

(Reporter: pwd.mozilla, Unassigned)

References

()

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150728111723

Steps to reproduce:

This is a relatively simple one. Basically we need to shift the menu that opens up around 36dpi in order to make it behave like the rest of the modern apps in the Play Store.
Attached image Gmail menu
It appears that on my Android L N4 (but not pre-L) other apps open the menu directly over the action bar. However, the content of their action bar contains less context than ours (i.e. the page url) so I can see the argument against not moving it upwards.

Anthony, thoughts?
Flags: needinfo?(alam)
Adding a link to the relevant page of the guidelines.
I think this is a good idea because the area in focus is going to be in the menu if it's triggered. 

But, it seems a bit awkward to do this without adopting more of the other Material design conventions. I'd like to do this at the same time as the other Material bugs like updating the toolbar.
Flags: needinfo?(alam)
Blocks: 1098596
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209967
It looks like this bug was marked a dupe incorrectly. 

Reopening.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Duplicate of this bug: 1265415
Status: REOPENED → NEW
OS: Unspecified → Android
Hardware: Unspecified → All
This will be happening as part of Bug 1269774, therefore marking as dupe!
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269774
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.